summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-21 01:53:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-21 01:53:54 +0000
commit3ec1aea96511815fc5a8dd564fb10057a7f92625 (patch)
treedd50d7de596e7d21e5c4b9fae40ff21607acad8a /sys-devel
parentmake sure ROOT always ends in a / (diff)
downloadhistorical-3ec1aea96511815fc5a8dd564fb10057a7f92625.tar.gz
historical-3ec1aea96511815fc5a8dd564fb10057a7f92625.tar.bz2
historical-3ec1aea96511815fc5a8dd564fb10057a7f92625.zip
fix the trailing / check for ROOT and silence grep if config doesnt exist
Package-Manager: portage-2.0.53
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/Manifest10
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.126
2 files changed, 13 insertions, 3 deletions
diff --git a/sys-devel/gcc-config/Manifest b/sys-devel/gcc-config/Manifest
index 2d5e4b5eaf8f..05be368ea610 100644
--- a/sys-devel/gcc-config/Manifest
+++ b/sys-devel/gcc-config/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 68d7c52689871082544aeb69f4022805 ChangeLog 22219
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-gcc-config-1.3.12-r4 0
MD5 c7cf3a3617d90adfaacc7c2c012ddfb0 files/digest-gcc-config-2.0.0_beta2 79
@@ -6,3 +9,10 @@ MD5 1b19cf481e2777dff9722f36698c3b24 files/wrapper-1.4.7.c 9837
MD5 c9487fb4c13f7250b9dc782f6e8f5358 gcc-config-1.3.12-r4.ebuild 1379
MD5 35fee17d74ce037258c00f8d9e9dd820 gcc-config-2.0.0_beta2.ebuild 781
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDqLXr2+ySkm8kpY0RAvzAAJ9jlRKk//qQXy3GcKASO1U62JuwMgCgxwnQ
+cClVm22EPjxhqu5P9d8JUZA=
+=HTYp
+-----END PGP SIGNATURE-----
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.12 b/sys-devel/gcc-config/files/gcc-config-1.3.12
index fd1cbec0ddcb..2b08e80c2feb 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.12
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.12
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.10 2005/12/03 20:49:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.12,v 1.11 2005/12/21 01:53:54 vapier Exp $
trap ":" INT QUIT TSTP
@@ -353,7 +353,7 @@ list_profiles() {
eerror "$0: No gcc profile is active; please select one!"
fi
- eval $(grep ^CURRENT= "${GCC_ENV_D}"/config)
+ eval $(grep -s ^CURRENT= "${GCC_ENV_D}"/config)
CURRENT_NATIVE=${CURRENT}
local target=
for x in "${GCC_ENV_D}"/* ; do
@@ -501,7 +501,7 @@ FORCE="no"
CC_COMP=
[[ -z ${ROOT} ]] && ROOT="/"
-[[ ${ROOT:-1} != "/" ]] && ROOT="${ROOT}/"
+[[ ${ROOT:0-1} != "/" ]] && ROOT="${ROOT}/"
ENV_D="${ROOT}etc/env.d"
GCC_ENV_D="${ENV_D}/gcc"