summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-24 05:11:20 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-24 05:11:20 +0000
commit140fd60093e911987f3918464c3516e26a194691 (patch)
tree0bd7644a84f4ebe7b79945344a68d78280fb08c2 /sys-devel/patch
parentFix use invocation and regenerate broken manifest (diff)
downloadhistorical-140fd60093e911987f3918464c3516e26a194691.tar.gz
historical-140fd60093e911987f3918464c3516e26a194691.tar.bz2
historical-140fd60093e911987f3918464c3516e26a194691.zip
QA - fix use invocation. This also fixes an ebuild error due in part to the less readable use syntax. It was written [ "is-ldflags -pie" ] when it should have been [ "`is-ldflags -pie`" ]. The way it was written would have always evaluated to true.
Diffstat (limited to 'sys-devel/patch')
-rw-r--r--sys-devel/patch/ChangeLog9
-rw-r--r--sys-devel/patch/Manifest6
-rw-r--r--sys-devel/patch/patch-2.5.4-r5.ebuild6
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild4
4 files changed, 16 insertions, 9 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index 31e737ad5ab1..feeecfe41299 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/patch
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.22 2004/06/22 17:08:34 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.23 2004/06/24 05:11:20 agriffis Exp $
+
+ 24 Jun 2004; Aron Griffis <agriffis@gentoo.org> patch-2.5.4-r5.ebuild,
+ patch-2.5.9.ebuild:
+ QA - fix use invocation. This also fixes an ebuild error due in part to the
+ less readable use syntax. It was written [ "is-ldflags -pie" ] when it should
+ have been [ "`is-ldflags -pie`" ]. The way it was written would have always
+ evaluated to true.
22 Jun 2004; <solar@gentoo.org> patch-2.5.9.ebuild:
Fixed unary operator problem because LDFLAGS_PIE does not exist in most of the
diff --git a/sys-devel/patch/Manifest b/sys-devel/patch/Manifest
index 5abb36287805..5503ec32bef6 100644
--- a/sys-devel/patch/Manifest
+++ b/sys-devel/patch/Manifest
@@ -1,6 +1,6 @@
-MD5 0e9e9ae3a676f3d2228570a541fef56e patch-2.5.9.ebuild 1457
-MD5 c85af77037c7025f2492be5a86e5caf7 patch-2.5.4-r5.ebuild 913
-MD5 308eef1c07ddddc13006be463695d00f ChangeLog 2956
+MD5 63e9e7f86f7912afdc910a9a2dce8371 patch-2.5.9.ebuild 1446
+MD5 ee36fd391d5b4485a8cd5dc055a895c9 patch-2.5.4-r5.ebuild 894
+MD5 80283ccfaabbad57b211c7c80dbebb0a ChangeLog 3312
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 7113f2413944cb06cecdd0c57ab54078 files/digest-patch-2.5.9 63
MD5 d8308835b63cc0644a67523856ef2df8 files/digest-patch-2.5.4-r5 63
diff --git a/sys-devel/patch/patch-2.5.4-r5.ebuild b/sys-devel/patch/patch-2.5.4-r5.ebuild
index 427c0da26d0d..b1cf16c75d87 100644
--- a/sys-devel/patch/patch-2.5.4-r5.ebuild
+++ b/sys-devel/patch/patch-2.5.4-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.4-r5.ebuild,v 1.6 2004/02/22 12:44:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.4-r5.ebuild,v 1.7 2004/06/24 05:11:20 agriffis Exp $
DESCRIPTION="Utility to apply diffs to files"
HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
@@ -17,7 +17,7 @@ src_compile() {
CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
ac_cv_sys_long_file_names=yes \
./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
- if [ -z "`use static`" ]; then
+ if ! use static; then
emake || die "emake failed"
else
emake LDFLAGS=-static || die "emake failed"
@@ -26,7 +26,7 @@ src_compile() {
src_install() {
einstall
- if [ -z "`use build`" ]; then
+ if ! use build; then
dodoc AUTHORS COPYING ChangeLog NEWS README
else
rm -rf ${D}/usr/share/man
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
index 729c6c129406..5170174748ca 100644
--- a/sys-devel/patch/patch-2.5.9.ebuild
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.17 2004/06/22 17:08:34 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.18 2004/06/24 05:11:20 agriffis Exp $
inherit flag-o-matic
@@ -21,7 +21,7 @@ src_compile() {
strip-flags
CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
# workaround for hardened on amd64, 1st part
- if [ "`use amd64`" ] && [ "is-ldflags -pie" ]; then
+ if use amd64 && is-ldflags -pie; then
einfo Stripping "-pie" from LDFLAGS, adding it to Makefile manually
filter-ldflags -pie
append-flags -fPIC