summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-15 03:27:17 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-15 03:27:17 +0000
commit53b1e30039e73d4995afe741a8202cc147cfa7f5 (patch)
treee49fc4e41bf7fb409ee964c16092ef61bf3f13a5 /sys-devel/libperl
parentFix use invocation (diff)
downloadhistorical-53b1e30039e73d4995afe741a8202cc147cfa7f5.tar.gz
historical-53b1e30039e73d4995afe741a8202cc147cfa7f5.tar.bz2
historical-53b1e30039e73d4995afe741a8202cc147cfa7f5.zip
Fix use invocation
Diffstat (limited to 'sys-devel/libperl')
-rw-r--r--sys-devel/libperl/ChangeLog6
-rw-r--r--sys-devel/libperl/Manifest6
-rw-r--r--sys-devel/libperl/libperl-5.8.2.ebuild16
-rw-r--r--sys-devel/libperl/libperl-5.8.3.ebuild16
4 files changed, 24 insertions, 20 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index beafdc7dda08..ad53624b1fab 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.30 2004/06/09 20:16:04 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.31 2004/06/15 03:27:17 agriffis Exp $
+
+ 14 Jun 2004; Aron Griffis <agriffis@gentoo.org> libperl-5.8.2.ebuild,
+ libperl-5.8.3.ebuild:
+ Fix use invocation
09 Jun 2004; Robert Coie <rac@gentoo.org> +files/libperl-5.8.4-noksh.patch,
libperl-5.8.4.ebuild:
diff --git a/sys-devel/libperl/Manifest b/sys-devel/libperl/Manifest
index 50c25628a199..0ec772bad6da 100644
--- a/sys-devel/libperl/Manifest
+++ b/sys-devel/libperl/Manifest
@@ -1,6 +1,6 @@
-MD5 c70aa9525be96a22398fbc7a1425cfb3 libperl-5.8.3.ebuild 10868
-MD5 f26389d2c42ee51afc479cfd659c5582 libperl-5.8.2.ebuild 10848
-MD5 29ab2af9471bcde9a214630ae47b7132 ChangeLog 4122
+MD5 97bb31d51318b78d7ebae99e1cda56f8 libperl-5.8.3.ebuild 10810
+MD5 3d6a4bd1a8dd160b2831a31902ea982f libperl-5.8.2.ebuild 10793
+MD5 6baa4a401e236081285c3067b0095f94 ChangeLog 4245
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
MD5 80aee96555074f8cf09c3ae4bf826414 libperl-5.8.4.ebuild 11068
MD5 0bdca74363c218d91a0db4ad1ea55485 files/libperl-5.8.3-create-libperl-soname.patch 417
diff --git a/sys-devel/libperl/libperl-5.8.2.ebuild b/sys-devel/libperl/libperl-5.8.2.ebuild
index 05a484e59004..6d4543168625 100644
--- a/sys-devel/libperl/libperl-5.8.2.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.11 2004/03/09 00:33:16 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.12 2004/06/15 03:27:17 agriffis Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -98,7 +98,7 @@ PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
- if [ -n "`use threads`" ]
+ if use threads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
@@ -142,7 +142,7 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if [ "`use threads`" ]
+ if use threads
then
einfo "using threads"
mythreading="-multi"
@@ -152,28 +152,28 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
- if [ "`use gdbm`" ]
+ if use gdbm
then
myconf="${myconf} -Di_gdbm"
fi
- if [ "`use berkdb`" ]
+ if use berkdb
then
myconf="${myconf} -Di_db -Di_ndbm"
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- if [ "`use mips`" ]
+ if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
- if [ "`use sparc`" ]
+ if use sparc
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use sparc64`" ]
+ if use sparc64
then
myconf="${myconf} -Ud_longdbl"
fi
diff --git a/sys-devel/libperl/libperl-5.8.3.ebuild b/sys-devel/libperl/libperl-5.8.3.ebuild
index b1a802ddbe60..0f312d62d6cd 100644
--- a/sys-devel/libperl/libperl-5.8.3.ebuild
+++ b/sys-devel/libperl/libperl-5.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.5 2004/04/25 07:57:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.6 2004/06/15 03:27:17 agriffis Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -98,7 +98,7 @@ PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
- if [ -n "`use threads`" ]
+ if use threads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
@@ -142,7 +142,7 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if [ "`use threads`" ]
+ if use threads
then
einfo "using threads"
mythreading="-multi"
@@ -152,28 +152,28 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
- if [ "`use gdbm`" ]
+ if use gdbm
then
myconf="${myconf} -Di_gdbm"
fi
- if [ "`use berkdb`" ]
+ if use berkdb
then
myconf="${myconf} -Di_db -Di_ndbm"
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- if [ "`use mips`" ]
+ if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
- if [ "`use sparc`" ]
+ if use sparc
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use sparc64`" ]
+ if use sparc64
then
myconf="${myconf} -Ud_longdbl"
fi