summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-20 19:05:41 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-20 19:05:41 +0000
commit9acc5cd797653b90750bb7acab47067b0a444e81 (patch)
treeb80bf1355784ddbe03811b483fbae259aeb70b60 /sys-devel/bison
parentnew _pre28 release (diff)
downloadhistorical-9acc5cd797653b90750bb7acab47067b0a444e81.tar.gz
historical-9acc5cd797653b90750bb7acab47067b0a444e81.tar.bz2
historical-9acc5cd797653b90750bb7acab47067b0a444e81.zip
new gcc 3.0 compatible bison
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/bison-1.34.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-devel/bison/bison-1.34.ebuild b/sys-devel/bison/bison-1.34.ebuild
new file mode 100644
index 000000000000..f849b861dee8
--- /dev/null
+++ b/sys-devel/bison/bison-1.34.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.34.ebuild,v 1.1 2002/03/20 19:05:41 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A yacc-compatible parser generator"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/bison/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ -z "`use static`" ]
+ then
+ emake ${MAKEOPTS} || die
+ else
+ emake ${MAKEOPTS} LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING AUTHORS NEWS ChangeLog README REFERENCES OChangeLog
+ docinto txt
+ dodoc doc/FAQ
+ else
+ rm -rf ${D}/usr/share/man ${D}/usr/share/info
+ fi
+}
+