summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-08-01 23:16:50 +0000
committerMichael Imhof <tantive@gentoo.org>2003-08-01 23:16:50 +0000
commitc7e9efdc40df6263d0f055922d744a45ff8e36a6 (patch)
tree3ba2c218936a32ecae4573be973301e5dccb9a3d /sys-cluster/cppvm/cppvm-1.5.0-r1.ebuild
parentInitial import. Submitted by the <the@weird-birds>. (diff)
downloadhistorical-c7e9efdc40df6263d0f055922d744a45ff8e36a6.tar.gz
historical-c7e9efdc40df6263d0f055922d744a45ff8e36a6.tar.bz2
historical-c7e9efdc40df6263d0f055922d744a45ff8e36a6.zip
Initial import. Submitted by the <the@weird-birds>.
Diffstat (limited to 'sys-cluster/cppvm/cppvm-1.5.0-r1.ebuild')
-rw-r--r--sys-cluster/cppvm/cppvm-1.5.0-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-cluster/cppvm/cppvm-1.5.0-r1.ebuild b/sys-cluster/cppvm/cppvm-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..34150eaeab89
--- /dev/null
+++ b/sys-cluster/cppvm/cppvm-1.5.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cppvm/cppvm-1.5.0-r1.ebuild,v 1.1 2003/08/01 23:16:33 tantive Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="CPPVM: A C++ Interface to PVM"
+SRC_URI="ftp://ftp.informatik.uni-stuttgart.de/pub/cppvm/cppvm.tar.gz"
+HOMEPAGE="http://www.informatik.uni-stuttgart.de/ipvr/bv/cppvm/index.html"
+IUSE=""
+
+DEPEND=">=sys-cluster/pvm-3.4.1-r1"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="LGPL-2"
+
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${WORKDIR}/cppvm
+
+# export PVM_ROOT="/usr/local/pvm3"
+# export PVM_ARCH="LINUX"
+
+ emake || die
+}
+
+src_install() {
+ cd ${WORKDIR}
+ dodir ${PVM_ROOT}/bin/${PVM_ARCH}
+ dodir ${HOME}/pvm3/bin/${PVM_ARCH}
+ cd cppvm
+
+ export PVM_ROOT=${D}/${PVM_ROOT}
+ export HOME=${D}/${HOME}
+# export PVM_ARCH="LINUX"
+
+ einstall
+
+ #install headers and libs
+ cp ${WORKDIR}/cppvm ${PVM_ROOT} -r
+
+ dodoc CONTACT LICENCE README VERSION doc/cppvm.ps
+
+}
+
+pkg_postinst() {
+ ewarn "Do not forget do copy the /root/pvm3 dir to the homedirs of all users"
+ ewarn "that should be allowed access to cppvm!"
+}
+