summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ostrow <dostrow@gentoo.org>2004-05-23 18:03:58 +0000
committerDaniel Ostrow <dostrow@gentoo.org>2004-05-23 18:03:58 +0000
commitfaecc031b341caaec701489c549dd105c5097e7f (patch)
tree61c3a8b402752cf8d79a745da805e4d613d7f4cb /sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
parentPPC stable profile update (diff)
downloadhistorical-faecc031b341caaec701489c549dd105c5097e7f.tar.gz
historical-faecc031b341caaec701489c549dd105c5097e7f.tar.bz2
historical-faecc031b341caaec701489c549dd105c5097e7f.zip
Added 2 patches for compatibility
Diffstat (limited to 'sys-boot/yaboot/yaboot-1.3.12-r1.ebuild')
-rw-r--r--sys-boot/yaboot/yaboot-1.3.12-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild b/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
new file mode 100644
index 000000000000..7a16ca476d9f
--- /dev/null
+++ b/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/yaboot/yaboot-1.3.12-r1.ebuild,v 1.1 2004/05/23 18:03:58 dostrow Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PPC Bootloader"
+SRC_URI="http://penguinppc.org/projects/yaboot/${P}.tar.gz"
+HOMEPAGE="http://penguinppc.org/projects/yaboot/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc -x86 -amd64 -alpha -hppa -mips -sparc ~ppc64"
+
+DEPEND="sys-apps/powerpc-utils
+ sys-fs/hfsutils
+ sys-fs/hfsplusutils"
+
+PROVIDE="virtual/bootloader"
+
+MAKEOPTS='PREFIX=/usr MANDIR=share/man'
+
+src_compile() {
+ export -n CFLAGS
+ export -n CXXFLAGS
+ [ -n "${CC}" ] || CC="gcc"
+ # dual boot patch
+ epatch ${FILESDIR}/yabootconfig-${PV}.patch
+ epatch ${FILESDIR}/chrpfix.patch
+ epatch ${FILESDIR}/yaboot-3.4.patch
+ epatch ${FILESDIR}/yaboot-1.3.12-k2sata-ofpath.patch
+ emake ${MAKEOPTS} CC="${CC}" || die
+}
+
+src_install() {
+ cp etc/yaboot.conf etc/yaboot.conf.bak
+ sed -e 's/\/local//' etc/yaboot.conf >| etc/yaboot.conf.edit
+ mv -f etc/yaboot.conf.edit etc/yaboot.conf
+ make ROOT=${D} ${MAKEOPTS} install || die
+}
+