summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-11 00:17:55 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-11 00:17:55 +0000
commit39cd6ef5001ba6559b4c19941ecb48eb25d32517 (patch)
treee32e626fd0c1edcedcc8ff90ec72d66bd4dc70d2 /sys-boot/grub
parent-gnutls net-libs/gnutls (diff)
downloadhistorical-39cd6ef5001ba6559b4c19941ecb48eb25d32517.tar.gz
historical-39cd6ef5001ba6559b4c19941ecb48eb25d32517.tar.bz2
historical-39cd6ef5001ba6559b4c19941ecb48eb25d32517.zip
add support for multilib searching and touchup the automatic grub update
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/Manifest8
-rw-r--r--sys-boot/grub/grub-0.97-r2.ebuild15
2 files changed, 12 insertions, 11 deletions
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
index 3bf98495ed79..92fadc88bf05 100644
--- a/sys-boot/grub/Manifest
+++ b/sys-boot/grub/Manifest
@@ -14,13 +14,13 @@ MD5 c634a95c2668abba2e886a917b363d5d grub-0.94-r1.ebuild 3528
MD5 39a70f2e6c41b7e432c0f5603d01c1da grub-0.96-r1.ebuild 4742
MD5 bb061c69fc3ad3e5484726111bacb933 grub-0.96-r2.ebuild 4597
MD5 80623fad414fd78bb04b0479b94d76df grub-0.96-r3.ebuild 4577
-MD5 5fd192ab55a660ce5e6e9c8edb8a10f5 grub-0.97-r2.ebuild 4555
+MD5 ba21e231ee9aff03e8af77e54428d016 grub-0.97-r2.ebuild 4634
MD5 98aac6dc17a7d909ca1de859ef1394a2 grub-0.97.ebuild 4518
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDcrKIgIKl8Uu19MoRAjHUAJ9kEtGXtO3YCy6MYFtDDoECNvqppwCfSU65
-UlTLmeEVP2na9z+V1ZGzNN0=
-=VqoQ
+iD8DBQFDc+NngIKl8Uu19MoRAqAdAJ9R+GiUsPWdJRjh4tohA7PVBh9wWwCfcjKn
+B28chBZj94180GVVUtfZ1js=
+=jVqi
-----END PGP SIGNATURE-----
diff --git a/sys-boot/grub/grub-0.97-r2.ebuild b/sys-boot/grub/grub-0.97-r2.ebuild
index 9bef418d7c18..4af9d32793d6 100644
--- a/sys-boot/grub/grub-0.97-r2.ebuild
+++ b/sys-boot/grub/grub-0.97-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r2.ebuild,v 1.1 2005/11/10 02:37:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r2.ebuild,v 1.2 2005/11/11 00:17:55 vapier Exp $
inherit mount-boot eutils flag-o-matic toolchain-funcs
@@ -144,13 +144,14 @@ pkg_postinst() {
[[ -e /boot/grub/stage2 ]] && mv /boot/grub/stage2{,.old}
einfo "Copying files from /lib/grub and /usr/lib/grub to /boot"
- for x in /lib/grub/*/* /usr/lib/grub/*/* ; do
- [[ -f ${x} ]] && cp -p ${x} /boot/grub
+ for x in /lib*/grub/*/* /usr/lib*/grub/*/* ; do
+ [[ -f ${x} ]] && cp -p ${x} /boot/grub/
done
- [[ -e /boot/grub/grub.conf ]] \
- && /sbin/grub \
- --batch \
+ if [[ -e /boot/grub/grub.conf ]] ; then
+ egrep -v '^[[:space:]]*(#|$|default|fallback|splashimage|timeout|title)' /boot/grub/grub.conf | \
+ /sbin/grub --batch \
--device-map=/boot/grub/device.map \
- < /boot/grub/grub.conf > /dev/null 2>&1
+ > /dev/null
+ fi
}