summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-02-27 05:05:38 +0000
committerTim Harder <radhermit@gentoo.org>2014-02-27 05:05:38 +0000
commit5763ec3a0dc71324787562236389ab1b6803fce4 (patch)
tree2cc960a44b856e0853ab3cb9e29032e2aa117b45 /sys-block/fio/fio-2.1.5.ebuild
parentsci-physics/lammps-20140214-r2: Add Voronoi package. (diff)
downloadhistorical-5763ec3a0dc71324787562236389ab1b6803fce4.tar.gz
historical-5763ec3a0dc71324787562236389ab1b6803fce4.tar.bz2
historical-5763ec3a0dc71324787562236389ab1b6803fce4.zip
Version bump.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'sys-block/fio/fio-2.1.5.ebuild')
-rw-r--r--sys-block/fio/fio-2.1.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-block/fio/fio-2.1.5.ebuild b/sys-block/fio/fio-2.1.5.ebuild
new file mode 100644
index 000000000000..dc2849415fcb
--- /dev/null
+++ b/sys-block/fio/fio-2.1.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/fio/fio-2.1.5.ebuild,v 1.1 2014/02/27 05:05:34 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+inherit eutils flag-o-matic python-r1 toolchain-funcs
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Jens Axboe's Flexible IO tester"
+HOMEPAGE="http://brick.kernel.dk/snaps/"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="gtk"
+
+DEPEND="dev-libs/libaio
+ gtk? ( x11-libs/gtk+:2 )"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i '/^DEBUGFLAGS/s, -D_FORTIFY_SOURCE=2,,g' Makefile || die
+ epatch_user
+}
+
+src_configure() {
+ # not a real configure script
+ ./configure \
+ --extra-cflags="${CFLAGS}" --cc="$(tc-getCC)" \
+ $(use gtk && echo "--enable-gfio") || die 'configure failed'
+}
+
+src_compile() {
+ append-flags -W
+ emake V=1 OPTFLAGS=
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man"
+ python_replicate_script "${ED}/usr/bin/fio2gnuplot"
+ dodoc README REPORTING-BUGS HOWTO
+ docinto examples
+ dodoc examples/*
+ doman fio.1
+}