summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-07-11 12:37:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-07-11 12:37:52 +0000
commit25ae5fc165b0e61c09db6922482decfae7fdc1fe (patch)
treeed1bd022b345c6a488f306f6325c1bd220d1ce68 /sys-auth/pam_passwdqc/pam_passwdqc-1.0.4.ebuild
parentAdding package provided by elvantor <elvantor2007@gmail.com> after some minor... (diff)
downloadhistorical-25ae5fc165b0e61c09db6922482decfae7fdc1fe.tar.gz
historical-25ae5fc165b0e61c09db6922482decfae7fdc1fe.tar.bz2
historical-25ae5fc165b0e61c09db6922482decfae7fdc1fe.zip
Version bump, and solve a few issues like the ignored cflags and the pre-stripped binary.
Package-Manager: portage-2.1.3_rc7
Diffstat (limited to 'sys-auth/pam_passwdqc/pam_passwdqc-1.0.4.ebuild')
-rw-r--r--sys-auth/pam_passwdqc/pam_passwdqc-1.0.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-auth/pam_passwdqc/pam_passwdqc-1.0.4.ebuild b/sys-auth/pam_passwdqc/pam_passwdqc-1.0.4.ebuild
new file mode 100644
index 000000000000..afadb165d01b
--- /dev/null
+++ b/sys-auth/pam_passwdqc/pam_passwdqc-1.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_passwdqc/pam_passwdqc-1.0.4.ebuild,v 1.1 2007/07/11 12:37:52 flameeyes Exp $
+
+inherit pam eutils toolchain-funcs
+
+DESCRIPTION="Password strength checking for PAM aware password changing programs"
+HOMEPAGE="http://www.openwall.com/passwdqc/"
+SRC_URI="http://www.openwall.com/pam/modules/pam_passwdqc/${P}.tar.gz"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+DEPEND="virtual/pam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake \
+ OPTCFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ || die "emake failed"
+}
+
+src_install() {
+ dopammod pam_passwdqc.so
+
+ doman pam_passwdqc.8
+ dodoc README PLATFORMS INTERNALS LICENSE
+}
+
+pkg_postinst() {
+ elog
+ elog "To activate pam_passwdqc use pam_passwdqc.so instead"
+ elog "of pam_cracklib.so in /etc/pam.d/system-auth."
+ elog "Also, if you want to change the parameters, read up"
+ elog "on the pam_passwdqc(8) man page."
+ elog
+}