summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-12-04 22:17:14 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-12-04 22:17:14 +0000
commitf84ae50964c0eba490f0fdcb333c030a3b06fb96 (patch)
tree1df5ca61f6ddde8e2aca278ceab5641324ddbff6 /sys-auth/nss-ldapd
parentAdd python_need_rebuild, bug #244749. (diff)
downloadhistorical-f84ae50964c0eba490f0fdcb333c030a3b06fb96.tar.gz
historical-f84ae50964c0eba490f0fdcb333c030a3b06fb96.tar.bz2
historical-f84ae50964c0eba490f0fdcb333c030a3b06fb96.zip
add new nss-ldapd package which is a fork of nss_ldap. It simplifies the code base and provides a small nss library that speaks to a local daemon that does all the LDAP communication. Due to the way NSS works, this will improve interaction with user programs since less code is being loaded into their process space.
Package-Manager: portage-2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64
Diffstat (limited to 'sys-auth/nss-ldapd')
-rw-r--r--sys-auth/nss-ldapd/ChangeLog14
-rw-r--r--sys-auth/nss-ldapd/Manifest15
-rw-r--r--sys-auth/nss-ldapd/files/nslcd.rc17
-rw-r--r--sys-auth/nss-ldapd/metadata.xml10
-rw-r--r--sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild41
5 files changed, 97 insertions, 0 deletions
diff --git a/sys-auth/nss-ldapd/ChangeLog b/sys-auth/nss-ldapd/ChangeLog
new file mode 100644
index 000000000000..01d6e898b684
--- /dev/null
+++ b/sys-auth/nss-ldapd/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sys-auth/nss-ldapd
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/ChangeLog,v 1.1 2008/12/04 22:17:14 cardoe Exp $
+
+*nss-ldapd-0.6.7 (04 Dec 2008)
+
+ 04 Dec 2008; Doug Goldstein <cardoe@gentoo.org> +files/nslcd.rc,
+ +nss-ldapd-0.6.7.ebuild:
+ add new nss-ldapd package which is a fork of nss_ldap. It simplifies the
+ code base and provides a small nss library that speaks to a local daemon
+ that does all the LDAP communication. Due to the way NSS works, this will
+ improve interaction with user programs since less code is being loaded
+ into their process space.
+
diff --git a/sys-auth/nss-ldapd/Manifest b/sys-auth/nss-ldapd/Manifest
new file mode 100644
index 000000000000..32ba12a82eaa
--- /dev/null
+++ b/sys-auth/nss-ldapd/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX nslcd.rc 433 RMD160 4e34d480f18e4e25daac1acde000e1566ae43387 SHA1 1daecefb8faed9781e16b5a2cc17fd2e699d8af8 SHA256 c05af2b00642ffe2221b3d0ed0fec7f179819bef8e687279096b70e0a88e8595
+DIST nss-ldapd-0.6.7.tar.gz 376893 RMD160 e8494ae71a23d1e9f458e4adb5446dc128262398 SHA1 dd984b9c53832cef445411e166f1f8f6117350cb SHA256 322803b7dd29107d3cec961527166c9b3440786f8a0cdb79fc5a23a62fb1c7fe
+EBUILD nss-ldapd-0.6.7.ebuild 1121 RMD160 508b22ec8e6873f19c182a259532188fcf3b861f SHA1 0fc892e8d297d6937e12797ead6db65d6abd4dd4 SHA256 9a47cee654fadf6884119f339fb027a62da21cfa8272be3a3cccbd81e3fbed17
+MISC ChangeLog 663 RMD160 14009fd102da8e9ae90d1fa22a4d58b2ffed01c1 SHA1 2776d025122936666dd4cde29ce2a520c5544141 SHA256 e87b5ef297bbe350e96c328f039bfbbba2076fa0f02c57d33a169f334aa29393
+MISC metadata.xml 249 RMD160 a6d8f8c77b7aa9c00354b9734fad35c6b715556c SHA1 e0e7d183a6079c2dc3422f6a2bc9ff78c59a7acb SHA256 d32e4832e4abc1c29f58427f90bc4c2ecd9677058ef2c6ccb85d69a72187d780
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAkk4VvgACgkQoeSe8B0zEfxOJACeOnWgUk1B9IrHgVbUii3+bxNV
+Y5QAn0T1rWp1U5xZLDv4HGKVRvZlkITR
+=zbZP
+-----END PGP SIGNATURE-----
diff --git a/sys-auth/nss-ldapd/files/nslcd.rc b/sys-auth/nss-ldapd/files/nslcd.rc
new file mode 100644
index 000000000000..79a7fbeeb900
--- /dev/null
+++ b/sys-auth/nss-ldapd/files/nslcd.rc
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/files/nslcd.rc,v 1.1 2008/12/04 22:17:14 cardoe Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ start-stop-daemon --start --pidfile /var/run/nslcd/nslcd.pid \
+ --exec /usr/sbin/nslcd
+}
+
+stop() {
+ start-stop-daemon --stop --pidfile /var/run/nslcd/nslcd.pid
+}
diff --git a/sys-auth/nss-ldapd/metadata.xml b/sys-auth/nss-ldapd/metadata.xml
new file mode 100644
index 000000000000..03a898950033
--- /dev/null
+++ b/sys-auth/nss-ldapd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd></herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild b/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild
new file mode 100644
index 000000000000..5e09048417a9
--- /dev/null
+++ b/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-ldapd/nss-ldapd-0.6.7.ebuild,v 1.1 2008/12/04 22:17:14 cardoe Exp $
+
+DESCRIPTION="NSS module for name lookups using LDAP"
+HOMEPAGE="http://ch.tudelft.nl/~arthur/nss-ldapd/"
+SRC_URI="http://ch.tudelft.nl/~arthur/nss-ldapd/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="net-nds/openldap
+ !sys-auth/nss_ldap"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf --enable-warnings --with-ldap-lib=openldap $(use_enable debug) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # for socket and pid file
+ mkdir "${D}"/var/run/nslcd
+
+ # init script
+ newinitd "${FILESDIR}"/nslcd.rc nslcd
+}
+
+pkg_postinst() {
+ elog
+ elog "For this to work you must configure /etc/nss-ldapd.conf"
+ elog "This configuration is similar to pam_ldap's /etc/ldap.conf"
+ elog
+ elog "After configuring it, you MUST add `nslcd` to be started"
+ elog "i.e. $ rc-update add nslcd default"
+}