summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-15 23:53:47 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-15 23:53:47 +0000
commitdd2237545e4d37dc391e422dde294738e8ae3ea5 (patch)
tree3c3c306b980f619a4dc8ee5b55ca761c96feda43 /sys-apps
parentforgot to change the name for -r4 (diff)
downloadhistorical-dd2237545e4d37dc391e422dde294738e8ae3ea5.tar.gz
historical-dd2237545e4d37dc391e422dde294738e8ae3ea5.tar.bz2
historical-dd2237545e4d37dc391e422dde294738e8ae3ea5.zip
resolve bug #183; add missing manpages; fail build when trying to build shared libs (didnt build in 4.0.1, but tried to add since previous version did have), so disable it just in case
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/shadow/files/chage7
-rw-r--r--sys-apps/shadow/files/digest-shadow-4.0.1-r11
-rw-r--r--sys-apps/shadow/shadow-4.0.1-r1.ebuild61
3 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/shadow/files/chage b/sys-apps/shadow/files/chage
new file mode 100644
index 000000000000..197f0857fd7d
--- /dev/null
+++ b/sys-apps/shadow/files/chage
@@ -0,0 +1,7 @@
+#%PAM-1.0
+# /etc/pam.d/shadow - sample PAM config file for all shadow utils like:
+# chpasswd, groupadd, groupdel, groupmod, newusers, useradd, userdel, usermod.
+auth sufficient /lib/security/pam_rootok.so
+auth required /lib/security/pam_permit.so
+account required /lib/security/pam_permit.so
+password required /lib/security/pam_permit.so
diff --git a/sys-apps/shadow/files/digest-shadow-4.0.1-r1 b/sys-apps/shadow/files/digest-shadow-4.0.1-r1
new file mode 100644
index 000000000000..8db93be0de4c
--- /dev/null
+++ b/sys-apps/shadow/files/digest-shadow-4.0.1-r1
@@ -0,0 +1 @@
+MD5 0d81d40d11ff7d1e0b061e4ab7976a9e shadow-4.0.1.tar.gz 966656
diff --git a/sys-apps/shadow/shadow-4.0.1-r1.ebuild b/sys-apps/shadow/shadow-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..ee965761ee10
--- /dev/null
+++ b/sys-apps/shadow/shadow-4.0.1-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.0.1-r1.ebuild,v 1.1 2002/01/15 23:53:47 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utilities to deal with user accounts"
+SRC_URI="ftp://ftp.pld.org.pl/software/shadow/${P}.tar.gz"
+DEPEND=">=sys-libs/pam-0.73 sys-devel/gettext"
+RDEPEND=">=sys-libs/pam-0.73"
+
+src_compile() {
+ ./configure \
+ --disable-desrpc \
+ --with-libcrypt \
+ --with-libcrack \
+ --with-libpam \
+ --enable-shared=no \
+ --enable-static=yes \
+ --host=${CHOST} || die "bad configure"
+ # Parallel make fails sometimes
+ make LDFLAGS="" || die "compile problem"
+}
+
+src_install() {
+ dodir /etc/default /etc/skel
+
+ make \
+ prefix=${D}/usr \
+ exec_prefix=${D} \
+ mandir=${D}/usr/share/man \
+ install || die "install problem"
+
+ mv ${D}/lib ${D}/usr
+ dosed -e "s:/lib:/usr/lib:" -e "s: libshadow.so':':" /usr/lib/libshadow.la
+ dosym /usr/bin/newgrp /usr/bin/sg
+ dosym /usr/sbin/useradd /usr/sbin/adduser
+ dosym /usr/sbin/vipw /usr/sbin/vigr
+ # remove dead links
+ rm -f ${D}/bin/{sg,vipw}
+
+ insinto /etc
+ # Using a securetty with devfs device names added
+ # (compat names kept for non-devfs compatibility)
+ insopts -m0600 ; doins ${FILESDIR}/securetty
+ insopts -m0600 ; doins ${S}/etc/login.access
+ insopts -m0644 ; doins ${S}/etc/limits
+ insopts -m0644 ; doins ${FILESDIR}/login.defs
+ insinto /etc/pam.d ; insopts -m0644
+ doins ${FILESDIR}/shadow
+ newins ${FILESDIR}/shadow groupadd
+ newins ${FILESDIR}/shadow useradd
+ doins ${FILESDIR}/chage chage
+ cd ${S}/doc
+ dodoc ANNOUNCE INSTALL LICENSE README WISHLIST
+ docinto txt
+ dodoc HOWTO LSM README.* *.txt
+
+ # install missing manpages
+ doman ${S}/man/{shadow.3,shadowconfig.8}
+}