summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-04 21:29:56 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-04 21:29:56 +0000
commitacbfd172108a5ffe6291ab620cca6b27710b44ff (patch)
tree8bd939ef58444f34310d280c57da1bbca07dbaa6 /sys-apps
parentadded examples useflag to dev-java/jmock (diff)
downloadhistorical-acbfd172108a5ffe6291ab620cca6b27710b44ff.tar.gz
historical-acbfd172108a5ffe6291ab620cca6b27710b44ff.tar.bz2
historical-acbfd172108a5ffe6291ab620cca6b27710b44ff.zip
touchups
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/netboot-base/Manifest8
-rw-r--r--sys-apps/netboot-base/netboot-base-20041007.ebuild13
2 files changed, 11 insertions, 10 deletions
diff --git a/sys-apps/netboot-base/Manifest b/sys-apps/netboot-base/Manifest
index f1b6c5eab3c6..4c5944eb8935 100644
--- a/sys-apps/netboot-base/Manifest
+++ b/sys-apps/netboot-base/Manifest
@@ -3,12 +3,12 @@ Hash: SHA1
MD5 d4969be6b3f1725977e3e6774a050257 ChangeLog 341
MD5 607dc51d1f0bcebda4b8fe238ddb7734 metadata.xml 286
-MD5 744a89fd993db8a021683b25112f8759 netboot-base-20041007.ebuild 942
+MD5 9deb2169eb73a07c104b51d77db9d7a8 netboot-base-20041007.ebuild 965
MD5 70bab51ddf543bb3c33317914b4c5fa3 files/digest-netboot-base-20041007 72
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.10 (GNU/Linux)
-iD8DBQFBZbLKHTu7gpaalycRAhcsAJ0auJZFjdnT2/p70nBzBLTsTqImAwCdF685
-rds3AKi1w7o0FOJXwdDINok=
-=+7kJ
+iD8DBQFB2wsDroRuSHgZdywRAjYOAJ0bAfVccBalJByUztdOOtaA8KKg8wCdER/Q
+yIt+yiSswW2FuG0ERzVQ11Q=
+=FBrL
-----END PGP SIGNATURE-----
diff --git a/sys-apps/netboot-base/netboot-base-20041007.ebuild b/sys-apps/netboot-base/netboot-base-20041007.ebuild
index 3b2579ff4a04..752745be8224 100644
--- a/sys-apps/netboot-base/netboot-base-20041007.ebuild
+++ b/sys-apps/netboot-base/netboot-base-20041007.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/netboot-base/netboot-base-20041007.ebuild,v 1.2 2004/10/07 21:18:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netboot-base/netboot-base-20041007.ebuild,v 1.3 2005/01/04 21:29:56 vapier Exp $
inherit gcc
@@ -19,24 +19,25 @@ DEPEND=""
S=${WORKDIR}
pkg_setup() {
- [ "${ROOT}" == "/" ] && die "refusing to emerge to /"
+ [[ ${ROOT} = "/" ]] && die "refusing to emerge to /"
}
src_compile() {
- $(gcc-getCC) ${CFLAGS} src/consoletype.c -o sbin/consoletype || die
- strip --strip-unneeded sbin/consoletype
+ $(tc-getCC) ${CFLAGS} src/consoletype.c -o sbin/consoletype || die
+ $(tc-getSTRIP) --strip-unneeded sbin/consoletype
}
src_install() {
- [ "${ROOT}" == "/" ] && die "refusing to install to /"
+ [[ ${ROOT} = "/" ]] && die "refusing to install to /"
rm -r src
cp -r * ${D}/
}
pkg_postinst() {
- cd ${ROOT}
+ cd "${ROOT}"
mkdir -p bin dev etc lib mnt proc sbin var
mkdir -p var/log
mkdir -p mnt/gentoo
ln -s . usr
+ ln -s . share
}