summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2009-02-09 17:09:19 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2009-02-09 17:09:19 +0000
commita1109d29ee59d1b7d15b4ea1816a3bce68b385b2 (patch)
tree6532908d32a8a5e6d69e0b1ef60a169f7de7c8bd /sys-apps
parentBundle man pages to avoid docbook stuff #258241 by BedOS_Gui. (diff)
downloadhistorical-a1109d29ee59d1b7d15b4ea1816a3bce68b385b2.tar.gz
historical-a1109d29ee59d1b7d15b4ea1816a3bce68b385b2.tar.bz2
historical-a1109d29ee59d1b7d15b4ea1816a3bce68b385b2.zip
Use the correct CC and don't gzip man by default.
Authorized by maintainer Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/inotail/ChangeLog9
-rw-r--r--sys-apps/inotail/inotail-0.5-r1.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/sys-apps/inotail/ChangeLog b/sys-apps/inotail/ChangeLog
index b21c683ffbe9..bb0862a58e4f 100644
--- a/sys-apps/inotail/ChangeLog
+++ b/sys-apps/inotail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/inotail
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/inotail/ChangeLog,v 1.6 2008/04/21 18:28:23 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/inotail/ChangeLog,v 1.7 2009/02/09 17:09:19 drizzt Exp $
+
+*inotail-0.5-r1 (09 Feb 2009)
+
+ 09 Feb 2009; Timothy Redaelli <drizzt@gentoo.org> +inotail-0.5-r1.ebuild:
+ Use the correct CC and don't gzip man by default. Authorized by maintainer
21 Apr 2008; Raúl Porcel <armin76@gentoo.org> inotail-0.5.ebuild:
x86 stable
diff --git a/sys-apps/inotail/inotail-0.5-r1.ebuild b/sys-apps/inotail/inotail-0.5-r1.ebuild
new file mode 100644
index 000000000000..b7ee9cd55abc
--- /dev/null
+++ b/sys-apps/inotail/inotail-0.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/inotail/inotail-0.5-r1.ebuild,v 1.1 2009/02/09 17:09:19 drizzt Exp $
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="tail replacement using inotify"
+HOMEPAGE="http://distanz.ch/inotail/"
+SRC_URI="http://distanz.ch/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="INOTIFY"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i 's/\s*gzip/#&/' "${S}"/Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake prefix="${D}/usr" install || die "install failed"
+ dodoc changelog README
+}