summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-24 19:00:52 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-24 19:00:52 +0000
commit989a8751230b29fe80432e2f36188bc7ac2f5e85 (patch)
tree58916644cf2a77d820cdf6af1945e783857170ff /sys-apps
parentMake sure we forces dashes in unicode to the traditional "-" so that users do... (diff)
downloadhistorical-989a8751230b29fe80432e2f36188bc7ac2f5e85.tar.gz
historical-989a8751230b29fe80432e2f36188bc7ac2f5e85.tar.bz2
historical-989a8751230b29fe80432e2f36188bc7ac2f5e85.zip
Do not force -c/-T anymore to groff so that it can work its locale magic #146315 by Matthias Schwarzott.
Package-Manager: portage-2.2_pre2
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/man/ChangeLog9
-rw-r--r--sys-apps/man/files/man-1.6f-unicode.patch28
-rw-r--r--sys-apps/man/man-1.6f-r1.ebuild110
3 files changed, 146 insertions, 1 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index c33a499586ef..b810843e84ce 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/man
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.126 2008/02/06 00:43:04 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.127 2008/02/24 19:00:51 vapier Exp $
+
+*man-1.6f-r1 (24 Feb 2008)
+
+ 24 Feb 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/man-1.6f-unicode.patch, +man-1.6f-r1.ebuild:
+ Do not force -c/-T anymore to groff so that it can work its locale magic
+ #146315 by Matthias Schwarzott.
06 Feb 2008; Christian Faulhammer <opfer@gentoo.org> man-1.6f.ebuild:
stable love, for bug 166190
diff --git a/sys-apps/man/files/man-1.6f-unicode.patch b/sys-apps/man/files/man-1.6f-unicode.patch
new file mode 100644
index 000000000000..89d3821df3ca
--- /dev/null
+++ b/sys-apps/man/files/man-1.6f-unicode.patch
@@ -0,0 +1,28 @@
+let the active locale work its magic
+
+http://bugs.gentoo.org/146315
+
+--- man-1.6f/configure
++++ man-1.6f/configure
+@@ -473,9 +473,9 @@
+ then
+ if test $Fnroff = "missing"
+ then
+- nroff="nroff -Tlatin1 -mandoc"
++ nroff="nroff -Tascii -c -mandoc"
+ else
+- nroff="$Fnroff -Tlatin1 -mandoc"
++ nroff="$Fnroff -mandoc"
+ fi
+ troff="troff -mandoc"
+ echo "Warning: could not find groff"
+@@ -484,7 +484,7 @@
+ then
+ nroff="$Fgroff -Tlatin1 -mandoc"
+ else
+- nroff="$Fnroff -Tlatin1 -mandoc"
++ nroff="$Fnroff -mandoc"
+ fi
+ troff="$Fgroff -Tps -mandoc"
+ jnroff="$Fgroff -Tnippon -mandocj"
+
diff --git a/sys-apps/man/man-1.6f-r1.ebuild b/sys-apps/man/man-1.6f-r1.ebuild
new file mode 100644
index 000000000000..6abed65334f2
--- /dev/null
+++ b/sys-apps/man/man-1.6f-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6f-r1.ebuild,v 1.1 2008/02/24 19:00:51 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Standard commands to read man pages"
+HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
+SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=">=sys-apps/groff-1.19.2-r1
+ !sys-apps/man-db
+ !app-arch/lzma"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/man-1.6f-man2html-compression.patch
+ epatch "${FILESDIR}"/man-1.6-cross-compile.patch
+ epatch "${FILESDIR}"/man-1.5p-search-order.patch
+ epatch "${FILESDIR}"/man-1.6f-unicode.patch #146315
+ epatch "${FILESDIR}"/man-1.5p-defmanpath-symlinks.patch
+ epatch "${FILESDIR}"/man-1.6b-more-sections.patch
+ epatch "${FILESDIR}"/man-1.6c-cut-duplicate-manpaths.patch
+ epatch "${FILESDIR}"/man-1.5m2-apropos.patch
+ epatch "${FILESDIR}"/man-1.6d-fbsd.patch
+ epatch "${FILESDIR}"/man-1.6e-headers.patch
+
+ strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
+}
+
+src_compile() {
+ unset NLSPATH #175258
+
+ tc-export CC BUILD_CC
+
+ local mylang=
+ if use nls ; then
+ if [[ -z ${LINGUAS} ]] ; then
+ mylang="all"
+ else
+ mylang="${LINGUAS// /,}"
+ fi
+ else
+ mylang="none"
+ fi
+ ./configure \
+ -confdir=/etc \
+ +sgid +fhs \
+ +lang ${mylang} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ unset NLSPATH #175258
+
+ emake PREFIX="${D}" install || die "make install failed"
+ dosym man /usr/bin/manpath
+
+ dodoc LSM README* TODO
+
+ # makewhatis only adds man-pages from the last 24hrs
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/makewhatis.cron makewhatis
+
+ keepdir /var/cache/man
+ diropts -m0775 -g man
+ local mansects=$(grep ^MANSECT "${D}"/etc/man.conf | cut -f2-)
+ for x in ${mansects//:/ } ; do
+ keepdir /var/cache/man/cat${x}
+ done
+}
+
+pkg_postinst() {
+ einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
+ chown -R root:man "${ROOT}"/var/cache/man
+ chmod -R g+w "${ROOT}"/var/cache/man
+ [[ -e ${ROOT}/var/cache/man/whatis ]] \
+ && chown root:0 "${ROOT}"/var/cache/man/whatis
+
+ echo
+
+ local f files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ for f in ${files} ; do
+ [[ ${f} == */etc/cron.daily/makewhatis ]] && continue
+ [[ $(md5sum "${f}") == "8b2016cc778ed4e2570b912c0f420266 "* ]] \
+ && rm -f "${f}"
+ done
+ files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ if [[ ${files/$'\n'} != ${files} ]] ; then
+ ewarn "You have multiple makewhatis cron files installed."
+ ewarn "You might want to delete all but one of these:"
+ ewarn ${files}
+ fi
+}