summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-06 00:47:11 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-06 00:47:11 +0000
commit6091ad3381e98530d5e64a0328b78ca8dac2e7e1 (patch)
tree9df7ac89aa763731c01796c43671af41c2f80b84 /sys-apps
parentMoved ruby back, as we don't have the time to fix all dev-lang inconsistencie... (diff)
downloadhistorical-6091ad3381e98530d5e64a0328b78ca8dac2e7e1.tar.gz
historical-6091ad3381e98530d5e64a0328b78ca8dac2e7e1.tar.bz2
historical-6091ad3381e98530d5e64a0328b78ca8dac2e7e1.zip
small fixes.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/portage-1.8.9_pre19.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-apps/portage/portage-1.8.9_pre19.ebuild b/sys-apps/portage/portage-1.8.9_pre19.ebuild
index ed52eb4b9193..d227881261ad 100644
--- a/sys-apps/portage/portage-1.8.9_pre19.ebuild
+++ b/sys-apps/portage/portage-1.8.9_pre19.ebuild
@@ -1,7 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc. Distributed under the terms
# of the GNU General Public License, v2 or later
-# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.8.9_pre19.ebuild,v 1.1 2002/03/05 20:35:28 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-1.8.9_pre19.ebuild,v 1.2 2002/03/06 00:47:11 drobbins Exp $
S=${WORKDIR}/${P}
SLOT="0"
@@ -13,6 +12,8 @@ HOMEPAGE="http://www.gentoo.org"
if [ -z "`use build`" ] ; then
RDEPEND=">=dev-lang/python-2.2 sys-apps/debianutils"
fi
+# note, the above three lines can eventually be replaced with:
+# RDEPEND=" !build? ( >=dev-lang/python-2.2 sys-apps/debianutils )"
src_unpack() {
#We are including the Portage bzipped tarball on CVS now, so that if a person's
@@ -51,8 +52,8 @@ src_install() {
doins xpak.py portage.py output.py
# we gotta compile these modules
- spython -c "import compileall; compileall.compile_dir('${D}/usr/lib/python2.2/site-packages')" || die
- spython -O -c "import compileall; compileall.compile_dir('${D}/usr/lib/python2.2/site-packages')" || die
+ python -c "import compileall; compileall.compile_dir('${D}/usr/lib/python2.2/site-packages')" || die
+ python -O -c "import compileall; compileall.compile_dir('${D}/usr/lib/python2.2/site-packages')" || die
#binaries, libraries and scripts
dodir /usr/lib/portage/bin