summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-07-05 20:11:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-07-05 20:11:39 +0000
commit6d048a94cf25762951315641c97d2ba1b09ff9b8 (patch)
tree26103b8ee52d6fc04f37f52f035dc2236b772e36 /sys-apps/x86info/x86info-1.24-r2.ebuild
parentFix prerm phase per bug #275918. (diff)
downloadhistorical-6d048a94cf25762951315641c97d2ba1b09ff9b8.tar.gz
historical-6d048a94cf25762951315641c97d2ba1b09ff9b8.tar.bz2
historical-6d048a94cf25762951315641c97d2ba1b09ff9b8.zip
modprobe.d filename style change for new modprobe.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'sys-apps/x86info/x86info-1.24-r2.ebuild')
-rw-r--r--sys-apps/x86info/x86info-1.24-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/x86info/x86info-1.24-r2.ebuild b/sys-apps/x86info/x86info-1.24-r2.ebuild
new file mode 100644
index 000000000000..fa93d61c5fd1
--- /dev/null
+++ b/sys-apps/x86info/x86info-1.24-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/x86info/x86info-1.24-r2.ebuild,v 1.1 2009/07/05 20:11:39 robbat2 Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dave Jones' handy, informative x86 CPU diagnostic utility"
+HOMEPAGE="http://www.codemonkey.org.uk/projects/x86info/"
+SRC_URI="http://www.codemonkey.org.uk/projects/x86info/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.21-pic.patch
+}
+
+src_compile() {
+ emake x86info CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+pkg_preinst() {
+ if [[ -a /etc/modules.d/x86info ]] && [[ ! -a /etc/modprobe.d/x86info ]]; then
+ elog "Moving old x86info configuration in modules.d to new"
+ elog "location in modprobe.d in /etc/"
+ mv "${ROOT}"/etc/{modules,modprobe}.d/x86info
+ fi
+ if [[ -a /etc/modprobe.d/x86info ]] && [[ ! -a /etc/modprobe.d/x86info.conf ]]; then
+ elog "Moving old x86info configuration in modprobe.d to"
+ elog "new naming scheme with trailing .conf"
+ mv "${ROOT}"/etc/modprobe.d/x86info{,.conf}
+ fi
+}
+
+src_install() {
+ dobin x86info || die
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/x86info-modules.conf-rc x86info.conf
+
+ dodoc TODO README
+ doman x86info.1
+ insinto /usr/share/doc/${PF}
+ doins -r results
+ prepalldocs
+}
+
+pkg_postinst() {
+ ewarn "Your kernel must be built with the following options"
+ ewarn "set to Y or M"
+ ewarn " Processor type and features ->"
+ ewarn " [*] /dev/cpu/*/msr - Model-specific register support"
+ ewarn " [*] /dev/cpu/*/cpuid - CPU information support"
+}