summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2003-10-04 16:14:29 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2003-10-04 16:14:29 +0000
commit4e6b76d79fc9139178b0ed529e9090ac9f8ba3ff (patch)
tree386322eb319018b73c51ed3ee8c16cadeaf4e469 /sys-apps/tpctl/tpctl-4.4-r1.ebuild
parentunmask to get gcc mergeable (diff)
downloadhistorical-4e6b76d79fc9139178b0ed529e9090ac9f8ba3ff.tar.gz
historical-4e6b76d79fc9139178b0ed529e9090ac9f8ba3ff.tar.bz2
historical-4e6b76d79fc9139178b0ed529e9090ac9f8ba3ff.zip
Fixes #26820.
Diffstat (limited to 'sys-apps/tpctl/tpctl-4.4-r1.ebuild')
-rw-r--r--sys-apps/tpctl/tpctl-4.4-r1.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/sys-apps/tpctl/tpctl-4.4-r1.ebuild b/sys-apps/tpctl/tpctl-4.4-r1.ebuild
index 3399aaf732c4..0219e34c6be9 100644
--- a/sys-apps/tpctl/tpctl-4.4-r1.ebuild
+++ b/sys-apps/tpctl/tpctl-4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/tpctl-4.4-r1.ebuild,v 1.1 2003/06/28 12:03:49 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tpctl/tpctl-4.4-r1.ebuild,v 1.2 2003/10/04 16:14:23 karltk Exp $
IUSE="ncurses tpctlir perl"
@@ -15,10 +15,18 @@ KEYWORDS="x86 amd64 -ppc -mips -sparc"
SLOT="0"
LICENSE="GPL-2"
-DEPEND="$DEPEND >=sys-apps/thinkpad-4.3 ncurses? ( sys-libs/ncurses )"
-RDEPEND="$RDEPEND >=sys-apps/thinkpad-4.3 ncurses? ( sys-libs/ncurses ) perl? ( dev-lang/perl )"
+DEPEND=">=sys-apps/thinkpad-4.3 ncurses? ( sys-libs/ncurses )"
+RDEPEND=">=sys-apps/thinkpad-4.3 ncurses? ( sys-libs/ncurses )
+ perl? ( dev-lang/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/tpctlir-cli-4.4-r1.diff
+}
src_compile() {
+
emake -C lib || die "lib make failed"
emake -C tpctl || die "tpctl make failed"
if use ncurses > /dev/null; then