summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
committerPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
commit60baf14c24fd458bc9a965a81ed7d3ebeb831262 (patch)
tree075007d8cef3f6a326d566ed10b8f8bf333dc2e5 /sys-apps/textutils
parentapply a patch that makes it work better with autoconf 2.13 (diff)
downloadhistorical-60baf14c24fd458bc9a965a81ed7d3ebeb831262.tar.gz
historical-60baf14c24fd458bc9a965a81ed7d3ebeb831262.tar.bz2
historical-60baf14c24fd458bc9a965a81ed7d3ebeb831262.zip
bootcd fixups and additions. set USE=bootcd to build these packages
for the installation cd. autoiso.sh is the cd building automation script. (its not nearly complete though)
Diffstat (limited to 'sys-apps/textutils')
-rw-r--r--sys-apps/textutils/files/digest-textutils-2.0.10-r31
-rw-r--r--sys-apps/textutils/textutils-2.0.10-r3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/textutils/files/digest-textutils-2.0.10-r3 b/sys-apps/textutils/files/digest-textutils-2.0.10-r3
new file mode 100644
index 000000000000..1c652739479f
--- /dev/null
+++ b/sys-apps/textutils/files/digest-textutils-2.0.10-r3
@@ -0,0 +1 @@
+MD5 420a7cd54d4ce4b44c412af1318f7c83 textutils-2.0.10.tar.gz
diff --git a/sys-apps/textutils/textutils-2.0.10-r3.ebuild b/sys-apps/textutils/textutils-2.0.10-r3.ebuild
new file mode 100644
index 000000000000..0b674e1dd85d
--- /dev/null
+++ b/sys-apps/textutils/textutils-2.0.10-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/textutils/textutils-2.0.10-r3.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU text utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
+ --host=${CHOST} --build=${CHOST} --without-included-regex ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ dodir /bin
+ mv ${D}/usr/bin/cat ${D}/bin
+ dosym /bin/cat /usr/bin/cat
+ rmdir ${D}/usr/lib
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ dodoc AUTHORS COPYING ChangeLog NEWS README* THANKS TODO
+ else
+ rm -rf ${D}/usr/share
+ fi
+
+}