summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-03-27 22:57:09 +0000
committerJoshua Brindle <method@gentoo.org>2003-03-27 22:57:09 +0000
commit40494f8e25529911c71d6f719cb14974bd4126f6 (patch)
treee5f2c850c720411548dc09bdf4ed804cdf419131 /sys-apps/systrace/systrace-1.0-r1.ebuild
parentunmasked for x86 (diff)
downloadhistorical-40494f8e25529911c71d6f719cb14974bd4126f6.tar.gz
historical-40494f8e25529911c71d6f719cb14974bd4126f6.tar.bz2
historical-40494f8e25529911c71d6f719cb14974bd4126f6.zip
systrace initial import
Diffstat (limited to 'sys-apps/systrace/systrace-1.0-r1.ebuild')
-rw-r--r--sys-apps/systrace/systrace-1.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-apps/systrace/systrace-1.0-r1.ebuild b/sys-apps/systrace/systrace-1.0-r1.ebuild
new file mode 100644
index 000000000000..5d7668a2dd95
--- /dev/null
+++ b/sys-apps/systrace/systrace-1.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+
+DESCRIPTION="Systrace userland binary"
+HOMEPAGE="http://www.citi.umich.edu/u/provos/systrace/index.html"
+SRC_URI="http://www.citi.umich.edu/u/provos/systrace/usr-systrace-2003-01-26.tar.gz
+ http://natey.com/gentoo/systrace/patches/systrace.c-no_x11-1.0.patch.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KERNEL="linux-2.4.20-systrace-r2"
+PATCH1="systrace.c-no_x11-1.0.patch"
+S="${WORKDIR}/${P}"
+
+KEYWORDS="~x86"
+IUSE="gtk"
+DEPEND="gtk? ( =x11-libs/gtk+-1.2* =dev-libs/glib-1.2* )"
+
+src_compile() {
+ cp /usr/src/${KERNEL}/include/linux/systrace.h /usr/include/linux/ || die
+ if [ "`use gtk`" ]
+ then
+ einfo
+ einfo "You are building systrace with gtk support; this version will not"
+ einfo "function without the sys-apps/gtk-systrace package installed. Please"
+ einfo "unset the gtk USE variable to build the non-gui capable version of"
+ einfo "systrace."
+ einfo
+ sleep 7
+ ./configure --host=${CHOST} || die
+ elif [ -z "`use gtk`" ]
+ then
+ einfo
+ einfo "You are building systrace without gtk support; please set the gtk USE"
+ einfo "variable to build the gui capable version of systrace."
+ einfo
+ sleep 7
+ cd ${S}
+ patch < ../${PATCH1} || die
+ ./configure --host=${CHOST} || die
+ fi
+
+ emake || die
+}
+
+src_install() {
+ dobin systrace
+ exeinto /usr/bin
+
+ doman systrace.1
+}