summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-17 06:12:50 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-17 06:12:50 +0000
commit1dd8f55933b8247790afe822ff12735bd8dedbbd (patch)
tree6176271ff971a14e7720e052d58760f6f19a73b0 /sys-apps/smartmontools/smartmontools-5.36-r1.ebuild
parentold (diff)
downloadhistorical-1dd8f55933b8247790afe822ff12735bd8dedbbd.tar.gz
historical-1dd8f55933b8247790afe822ff12735bd8dedbbd.tar.bz2
historical-1dd8f55933b8247790afe822ff12735bd8dedbbd.zip
Fix separator usage in UTF8 output #139409 by Samuli Suominen.
Package-Manager: portage-2.1.1_pre2-r8
Diffstat (limited to 'sys-apps/smartmontools/smartmontools-5.36-r1.ebuild')
-rw-r--r--sys-apps/smartmontools/smartmontools-5.36-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/smartmontools/smartmontools-5.36-r1.ebuild b/sys-apps/smartmontools/smartmontools-5.36-r1.ebuild
new file mode 100644
index 000000000000..8643b233be8e
--- /dev/null
+++ b/sys-apps/smartmontools/smartmontools-5.36-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/smartmontools/smartmontools-5.36-r1.ebuild,v 1.1 2006/07/17 06:12:50 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="control and monitor storage systems using the Self-Monitoring, Analysis and Reporting Technology System (S.M.A.R.T.)"
+HOMEPAGE="http://smartmontools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="static"
+
+RDEPEND="virtual/mailx"
+DEPEND=">=sys-apps/portage-2.0.51"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-utf8.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ dosbin smart{ctl,d} || die "dosbin"
+ doman *.[58]
+ dodoc AUTHORS CHANGELOG NEWS README TODO WARNINGS
+ newdoc smartd.conf smartd.conf.example
+ docinto examplescripts
+ dodoc examplescripts/*
+ rm -f "${D}"/usr/share/doc/${PF}/examplescripts/Makefile*
+
+ insinto /etc
+ doins smartd.conf
+
+ newinitd "${FILESDIR}"/smartd.rc smartd
+ newconfd "${FILESDIR}"/smartd.confd smartd
+}