summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2003-10-31 21:18:48 +0000
committerBrian Jackson <iggy@gentoo.org>2003-10-31 21:18:48 +0000
commit7e1dcb41ff736334032309fdb0441bdcb0e361f8 (patch)
tree6a340ffe916ae0a73921154a63d765e19b40361a /sys-apps/slocate
parentadding sysfs to PRUNEFS, closes bug 32345 (diff)
downloadhistorical-7e1dcb41ff736334032309fdb0441bdcb0e361f8.tar.gz
historical-7e1dcb41ff736334032309fdb0441bdcb0e361f8.tar.bz2
historical-7e1dcb41ff736334032309fdb0441bdcb0e361f8.zip
adding sysfs to PRUNEFS, closes bug 32345
Diffstat (limited to 'sys-apps/slocate')
-rw-r--r--sys-apps/slocate/ChangeLog4
-rw-r--r--sys-apps/slocate/files/digest-slocate-2.7-r31
-rw-r--r--sys-apps/slocate/files/updatedb.conf4
-rw-r--r--sys-apps/slocate/slocate-2.7-r3.ebuild70
4 files changed, 75 insertions, 4 deletions
diff --git a/sys-apps/slocate/ChangeLog b/sys-apps/slocate/ChangeLog
index df6c8189a4f9..34c7ac32674c 100644
--- a/sys-apps/slocate/ChangeLog
+++ b/sys-apps/slocate/ChangeLog
@@ -1,10 +1,10 @@
# ChangeLog for sys-apps/slocate
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/ChangeLog,v 1.25 2003/10/31 21:17:53 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/ChangeLog,v 1.26 2003/10/31 21:18:48 iggy Exp $
31 Oct 2003; Brian Jackson <iggy@gentoo.org> slocate-2.7-r3.ebuild
files/updatedb.conf:
- adding sysfs to PRUNEFS, closes bug 32345
+ adding sysfs to PRUNEFS, closes bug 32345, thanks to jforman@austin.rr.com
08 Oct 2003; <solar@gentoo.org> slocate-2.7-r2.ebuild:
permission fix for when sfperms is found in FEATURES, added a metadata.xml
diff --git a/sys-apps/slocate/files/digest-slocate-2.7-r3 b/sys-apps/slocate/files/digest-slocate-2.7-r3
new file mode 100644
index 000000000000..f312912325b1
--- /dev/null
+++ b/sys-apps/slocate/files/digest-slocate-2.7-r3
@@ -0,0 +1 @@
+MD5 4872830642ea2ed5f9aff932720583c9 slocate-2.7.tar.gz 87240
diff --git a/sys-apps/slocate/files/updatedb.conf b/sys-apps/slocate/files/updatedb.conf
index ceae9d6ac776..1261c28316b5 100644
--- a/sys-apps/slocate/files/updatedb.conf
+++ b/sys-apps/slocate/files/updatedb.conf
@@ -1,11 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/files/updatedb.conf,v 1.4 2003/04/18 02:42:14 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/files/updatedb.conf,v 1.5 2003/10/31 21:17:53 iggy Exp $
# This file sets environment variables which are used by updatedb
# filesystems which are pruned from updatedb database
-PRUNEFS="NFS nfs afs proc smbfs autofs auto iso9660 devfs tmpfs ncpfs"
+PRUNEFS="NFS nfs afs proc smbfs autofs auto iso9660 devfs tmpfs ncpfs sysfs"
export PRUNEFS
# paths which are pruned from updatedb database
PRUNEPATHS="/tmp /var/tmp"
diff --git a/sys-apps/slocate/slocate-2.7-r3.ebuild b/sys-apps/slocate/slocate-2.7-r3.ebuild
new file mode 100644
index 000000000000..e0eb9b049426
--- /dev/null
+++ b/sys-apps/slocate/slocate-2.7-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.7-r3.ebuild,v 1.1 2003/10/31 21:17:53 iggy Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Secure locate provides a secure way to index and quickly search for files on your system (drop-in replacement for 'locate')"
+HOMEPAGE="http://www.geekreview.org/slocate/"
+SRC_URI="ftp://ftp.geekreview.org/slocate/src/slocate-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64"
+
+DEPEND="sys-apps/shadow
+ >=sys-apps/sed-4"
+
+src_install() {
+
+ dodir /usr/share/man/man1
+
+ sed -i -e "/groupadd/s/^/#/;/chown.*slocate/s/^/#/" Makefile || die
+ make DESTDIR=${D} install || die
+
+ # make install for this package is blocked by sandbox
+ dosym slocate /usr/bin/locate
+ dosym slocate /usr/bin/updatedb
+ fperms 0755 /etc/cron.daily/slocate
+ keepdir /var/lib/slocate
+
+ # If this file doesn't exist, the first run of updatedb will create
+ # it anyway. But doing this shuts it up.
+ if [ ! -f ${ROOT}/var/lib/slocate/slocate.db ] ; then
+ touch ${D}/var/lib/slocate/slocate.db
+ fi
+
+ dodoc INSTALL LICENSE COPYING AUTHORS NEWS README ChangeLog
+
+ # man page fixing
+ rm -rf ${D}/usr/share/man/man1/locate.1.gz
+ dosym slocate.1.gz /usr/share/man/man1/locate.1.gz
+
+
+ insinto /etc
+ doins ${FILESDIR}/updatedb.conf
+ fperms 0644 /etc/updatedb.conf
+}
+
+pkg_postinst() {
+ touch /var/lib/slocate/slocate.db
+
+ # /var/lib/slocate is owned by group slocate and so is the executable
+ if ! groupmod slocate; then
+ groupadd slocate 2> /dev/null || die "Failed to create slocate group"
+ fi
+
+ chown root.slocate /usr/bin/slocate
+
+ # If nobody else minds I'd like to see 2711 become the system wide default. -solar
+ has sfperms ${FEATURES} && chmod 2711 /usr/bin/slocate || chmod 2755 /usr/bin/slocate
+
+ chown -R root.slocate /var/lib/slocate
+ chmod 0750 /var/lib/slocate
+
+ ewarn "If you merged slocate-2.7.ebuild, please remove"
+ ewarn "/etc/cron.daily/slocate.cron the .cron is no longer"
+ ewarn "in the filename"
+ echo
+ einfo "Note that the /etc/updatedb.conf file is generic"
+ einfo "Please customize it to your system requirements"
+}