summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-18 10:31:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-18 10:31:26 +0000
commite94fdf45ea81ea961ec7c978c77d4f95ac32d722 (patch)
tree074b336b2cdf895e9f6c79cee990023e26694673 /sys-apps/sed
parentAdd ~alpha to keywords. (diff)
downloadhistorical-e94fdf45ea81ea961ec7c978c77d4f95ac32d722.tar.gz
historical-e94fdf45ea81ea961ec7c978c77d4f95ac32d722.tar.bz2
historical-e94fdf45ea81ea961ec7c978c77d4f95ac32d722.zip
tidy the macos stuff
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/ChangeLog5
-rw-r--r--sys-apps/sed/Manifest4
-rw-r--r--sys-apps/sed/sed-4.0.9.ebuild29
3 files changed, 26 insertions, 12 deletions
diff --git a/sys-apps/sed/ChangeLog b/sys-apps/sed/ChangeLog
index 3951b32307e5..381482e06b70 100644
--- a/sys-apps/sed/ChangeLog
+++ b/sys-apps/sed/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/sed
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.56 2004/09/16 13:48:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/ChangeLog,v 1.57 2004/09/18 10:31:26 mr_bones_ Exp $
+
+ 18 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> sed-4.0.9.ebuild:
+ tidy the macos stuff
16 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> sed-4.0.9.ebuild:
Fixed use invocation; bug #64260.
diff --git a/sys-apps/sed/Manifest b/sys-apps/sed/Manifest
index d2175ab97e83..b1911519bfeb 100644
--- a/sys-apps/sed/Manifest
+++ b/sys-apps/sed/Manifest
@@ -1,9 +1,9 @@
-MD5 de952012b181b17b3289a5a868dee446 ChangeLog 7673
+MD5 3a0e235e7665e07cd98a0bc6359bfd64 ChangeLog 7774
MD5 6a956e3342c5e63efa3521477bc3fee1 sed-4.0.5.ebuild 916
MD5 770227e33780e037620fa66fe40ac076 sed-4.0.8.ebuild 1228
MD5 7c32f7da2670bc5c309a958dd45788d4 sed-4.0.7.ebuild 1214
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 efe94bffaa8123f0e0d1767aac46e79c sed-4.0.9.ebuild 1442
+MD5 ab565dcfe5d32f51650242da28a2feba sed-4.0.9.ebuild 1401
MD5 9b3e86e395686a7671a545d114aa2dd2 files/digest-sed-4.0.5 61
MD5 123861b697ac9119b4d3887608fa0fa1 files/digest-sed-4.0.8 61
MD5 a244109e1adcbd40a02446fb23df33c1 files/digest-sed-4.0.9 61
diff --git a/sys-apps/sed/sed-4.0.9.ebuild b/sys-apps/sed/sed-4.0.9.ebuild
index 8623b4382540..e45c18196eeb 100644
--- a/sys-apps/sed/sed-4.0.9.ebuild
+++ b/sys-apps/sed/sed-4.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.19 2004/09/16 13:48:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.0.9.ebuild,v 1.20 2004/09/18 10:31:26 mr_bones_ Exp $
inherit gnuconfig
@@ -21,9 +21,10 @@ src_compile() {
# Needed for mips and probably others
gnuconfig_update
- use macos && EXTRA_ECONF="--program-prefix=g"
- use ppc-macos && EXTRA_ECONF="--program-prefix=g"
- econf `use_enable nls` || die "Configure failed"
+ if use macos || use ppc-macos ; then
+ EXTRA_ECONF="--program-prefix=g"
+ fi
+ econf $(use_enable nls) || die "Configure failed"
if use static ; then
emake LDFLAGS=-static || die "Static build failed"
else
@@ -32,19 +33,29 @@ src_compile() {
}
src_install() {
+ local x
+
into /
dobin sed/sed
if ! use build
then
einstall || die "Install failed"
- dodoc COPYING NEWS README* THANKS AUTHORS BUGS ChangeLog
+ dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
docinto examples
- dodoc ${FILESDIR}/dos2unix ${FILESDIR}/unix2dos
+ dodoc "${FILESDIR}/dos2unix" "${FILESDIR}/unix2dos"
else
dodir /usr/bin
fi
- rm -f ${D}/usr/bin/sed
- ( use macos || use ppc-macos ) && cd ${D} && for x in `find . -name 'sed*' -print`; do mv "$x" "${x//sed/gsed}"; done && cd ${WORKDIR}/${P}
- ( use macos || use ppc-macos ) && dosym ../../bin/gsed /usr/bin/gsed || dosym ../../bin/sed /usr/bin/sed
+ rm -f "${D}/usr/bin/sed"
+ if use macos || use ppc-macos ; then
+ cd "${D}"
+ for x in $(find . -name 'sed*' -print);
+ do
+ mv "$x" "${x//sed/gsed}"
+ done
+ dosym ../../bin/gsed /usr/bin/gsed
+ else
+ dosym ../../bin/sed /usr/bin/sed
+ fi
}