summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-02 16:05:40 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-02 16:05:40 +0000
commitaa939c31b53eb21239139cfa2243b6d8c9969f85 (patch)
tree7cf4674aa5739ce1eb7b03e001df1a8e8dc08702 /sys-apps/sdparm/sdparm-1.08-r1.ebuild
parentFix for latest automake, bug #496772 by Arfrever Frehtes Taifersar Arahesis (diff)
downloadhistorical-aa939c31b53eb21239139cfa2243b6d8c9969f85.tar.gz
historical-aa939c31b53eb21239139cfa2243b6d8c9969f85.tar.bz2
historical-aa939c31b53eb21239139cfa2243b6d8c9969f85.zip
Fix depend on sg3_utils #479578 by Eric F. GARIOUD.
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0xD2E96200
Diffstat (limited to 'sys-apps/sdparm/sdparm-1.08-r1.ebuild')
-rw-r--r--sys-apps/sdparm/sdparm-1.08-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/sdparm/sdparm-1.08-r1.ebuild b/sys-apps/sdparm/sdparm-1.08-r1.ebuild
new file mode 100644
index 000000000000..589b029128ae
--- /dev/null
+++ b/sys-apps/sdparm/sdparm-1.08-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sdparm/sdparm-1.08-r1.ebuild,v 1.1 2014/01/02 16:05:35 vapier Exp $
+
+EAPI="4"
+
+DESCRIPTION="Utility to output and modify parameters on a SCSI device, like hdparm"
+HOMEPAGE="http://sg.danny.cz/sg/sdparm.html"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE=""
+
+# Older releases contain a conflicting sas_disk_blink
+RDEPEND=">=sys-apps/sg3_utils-1.28"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog CREDITS README notes.txt )
+
+src_configure() {
+ # sdparm ships with a local copy of this lib, but will use the system copy if it
+ # detects it (see the README file). Force the use of the system lib. #479578
+ export ac_cv_lib_sgutils2_sg_ll_inquiry=yes
+ default
+}
+
+src_install() {
+ default
+ dosbin scripts/sas*
+
+ # These don't exist yet. Someone wanna copy hdparm's and make them work? :)
+ #newinitd ${FILESDIR}/sdparm-init-7 sdparm
+ #newconfd ${FILESDIR}/sdparm-conf.d.3 sdparm
+}