summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-12 18:21:04 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-12 18:21:04 +0000
commit4ad50a8659399314e43236bfca682bbad4e0766c (patch)
treed1b19f36ab115d6a676619e063eb7d71e2fa48f2 /sys-apps/procps
parentchanged glib dep to 1.2* (diff)
downloadhistorical-4ad50a8659399314e43236bfca682bbad4e0766c.tar.gz
historical-4ad50a8659399314e43236bfca682bbad4e0766c.tar.bz2
historical-4ad50a8659399314e43236bfca682bbad4e0766c.zip
new procps in the 2.0 series from rik and them... unstable only for a moment
Diffstat (limited to 'sys-apps/procps')
-rw-r--r--sys-apps/procps/ChangeLog9
-rw-r--r--sys-apps/procps/files/digest-procps-2.0.111
-rw-r--r--sys-apps/procps/procps-2.0.11.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/sys-apps/procps/ChangeLog b/sys-apps/procps/ChangeLog
index d97ea24f8c89..6b79324adaaf 100644
--- a/sys-apps/procps/ChangeLog
+++ b/sys-apps/procps/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/procps
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.12 2002/12/09 04:51:20 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/ChangeLog,v 1.13 2002/12/12 18:21:04 lostlogic Exp $
+
+*procps-2.0.11 (12 Dec 2002)
+
+ 12 Dec 2002; Brandon Low <lostlogic@gentoo.org> procps-2.0.11.ebuild
+ files/digest-procps-2.0.11 :
+
+ Version bump. Set keywords to ~.
*procps-3.1.2 (08 Dec 2002)
diff --git a/sys-apps/procps/files/digest-procps-2.0.11 b/sys-apps/procps/files/digest-procps-2.0.11
new file mode 100644
index 000000000000..3e7032183b42
--- /dev/null
+++ b/sys-apps/procps/files/digest-procps-2.0.11
@@ -0,0 +1 @@
+MD5 8b9464631ebb02f1c2bcda16fb81d62f procps-2.0.11.tar.bz2 156294
diff --git a/sys-apps/procps/procps-2.0.11.ebuild b/sys-apps/procps/procps-2.0.11.ebuild
new file mode 100644
index 000000000000..0d77d4b429cd
--- /dev/null
+++ b/sys-apps/procps/procps-2.0.11.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/procps/procps-2.0.11.ebuild,v 1.1 2002/12/12 18:21:04 lostlogic Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard informational utilities and process-handling tools"
+SRC_URI="http://surriel.com/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://surriel.com/procps/"
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND} >=sys-devel/gettext-0.10.35"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Use the CFLAGS from /etc/make.conf.
+ # remove /etc/X11/applnk/Desktop/top.app from makefile
+ mv Makefile Makefile.orig
+ sed -e "s/-O3/${CFLAGS}/" -e 's/all: config/all: /' \
+ -e "s:--strip::" -e 's/$.DESKTOP.//' Makefile.orig > Makefile
+
+ # WARNING! In case of a version bump, check the line below that removes a line from the Makefile file.
+ cd ${S}/ps
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" -e "s:/var/.*man/:${D}var/.*man/:" -e "s:-lproc:-lproc -L${D}lib:" \
+ Makefile.orig > Makefile
+
+ cd ${S}/proc
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/" -e "s:--strip::" Makefile.orig > Makefile
+}
+
+src_compile() {
+ dodir /lib
+
+ make SHLIBDIR="${D}lib" || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /sbin
+ dodir /usr/X11R6/bin
+ dodir /usr/share/man/man{1,5,8}
+ dodir /lib
+ dodir /bin
+
+ exeinto /lib
+ doexe proc/libproc.so.${PV}
+ dosym /lib/libproc.so.${PV} /lib/libproc.so
+
+ einstall DESTDIR="${D}" || die
+
+ dodoc BUGS COPYING COPYING.LIB NEWS TODO
+ docinto proc
+ dodoc proc/COPYING
+ docinto ps
+ dodoc ps/COPYING ps/HACKING
+}
+
+pkg_postinst() {
+ einfo "NOTE: By default \"ps\" and \"top\" no longer"
+ einfo "show threads. You can use the '-m' flag"
+ einfo "in ps or the 'H' key in top to show them"
+}