summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-03-31 15:51:23 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-03-31 15:51:23 +0000
commit797e8579d105937c8ca6be8276cb5509a67bd085 (patch)
tree7c56d192e119014066a145ef96943f0f0c12f2d4 /sys-apps/hfsutils
parentfix bug 18427 on alpha (diff)
downloadhistorical-797e8579d105937c8ca6be8276cb5509a67bd085.tar.gz
historical-797e8579d105937c8ca6be8276cb5509a67bd085.tar.bz2
historical-797e8579d105937c8ca6be8276cb5509a67bd085.zip
errno fix
Diffstat (limited to 'sys-apps/hfsutils')
-rw-r--r--sys-apps/hfsutils/ChangeLog8
-rw-r--r--sys-apps/hfsutils/files/digest-hfsutils-3.2.6-r21
-rw-r--r--sys-apps/hfsutils/files/hfsutils-3.2.6-errno.patch13
-rw-r--r--sys-apps/hfsutils/hfsutils-3.2.6-r2.ebuild43
4 files changed, 63 insertions, 2 deletions
diff --git a/sys-apps/hfsutils/ChangeLog b/sys-apps/hfsutils/ChangeLog
index 776523b04b78..873f0ba6ac44 100644
--- a/sys-apps/hfsutils/ChangeLog
+++ b/sys-apps/hfsutils/ChangeLog
@@ -1,8 +1,12 @@
# ChangeLog for sys-apps/hfsutils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsutils/ChangeLog,v 1.6 2003/02/12 08:59:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsutils/ChangeLog,v 1.7 2003/03/31 15:51:22 lu_zero Exp $
+
+*hfsutils-3.2.6-r2 (31 Mar 2003)
+
+ 31 Mar 2003; Luca Barbato <lu_zero@gentoo.org> hfsutils-3.2.6-r2.ebuild:
+ Fix the errno issue on glibc-2.3.2
-
*hfsutils-3.2.6-r1 (04 Feb 2003)
04 Feb 2002; Jon Nall <nall@gentoo.org> hfsutils-3.2.6-r1.ebuild,
diff --git a/sys-apps/hfsutils/files/digest-hfsutils-3.2.6-r2 b/sys-apps/hfsutils/files/digest-hfsutils-3.2.6-r2
new file mode 100644
index 000000000000..7cdf8f29675b
--- /dev/null
+++ b/sys-apps/hfsutils/files/digest-hfsutils-3.2.6-r2
@@ -0,0 +1 @@
+MD5 fa572afd6da969e25c1455f728750ec4 hfsutils-3.2.6.tar.gz 207697
diff --git a/sys-apps/hfsutils/files/hfsutils-3.2.6-errno.patch b/sys-apps/hfsutils/files/hfsutils-3.2.6-errno.patch
new file mode 100644
index 000000000000..6e25f794b220
--- /dev/null
+++ b/sys-apps/hfsutils/files/hfsutils-3.2.6-errno.patch
@@ -0,0 +1,13 @@
+diff -ruN hfsutils.orig/tclhfs.c hfsutils-3.2.6/tclhfs.c
+--- hfsutils.orig/tclhfs.c 2003-03-31 17:34:55.000000000 +0200
++++ hfsutils-3.2.6/tclhfs.c 2003-03-31 17:39:51.000000000 +0200
+@@ -43,8 +43,7 @@
+ # include "charset.h"
+ # include "suid.h"
+ # include "version.h"
+-
+-extern int errno;
++# include <errno.h>
+
+ # define ERROR(code, str) (hfs_error = (str), errno = (code))
+
diff --git a/sys-apps/hfsutils/hfsutils-3.2.6-r2.ebuild b/sys-apps/hfsutils/hfsutils-3.2.6-r2.ebuild
new file mode 100644
index 000000000000..35b4c983f921
--- /dev/null
+++ b/sys-apps/hfsutils/hfsutils-3.2.6-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hfsutils/hfsutils-3.2.6-r2.ebuild,v 1.1 2003/03/31 15:51:23 lu_zero Exp $
+
+DESCRIPTION="HFS FS Access utils"
+SRC_URI="ftp://ftp.mars.org/pub/hfs/${P}.tar.gz"
+HOMEPAGE="http://www.mars.org/home/rob/proj/hfs/"
+IUSE="tcltk"
+
+KEYWORDS="~x86 ~ppc -sparc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ tcltk? ( dev-lang/tcl dev-lang/tk )"
+RDEPEND=""
+
+MAKEOPTS='PREFIX=/usr MANDIR=/usr/share/man'
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/hfsutils-3.2.6-errno.patch
+}
+
+src_compile() {
+ local myconf
+ use tcltk && myconf="--with-tcl --with-tk"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/lib
+ dodir /usr/share/man/man1
+ make \
+ prefix=${D}/usr \
+ MANDEST=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+}