summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-01-06 09:09:26 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-01-06 09:09:26 +0000
commit6fc25dc2387f72331e75fca2b8ddf47c93897d4a (patch)
tree4611ea2e3b70bf0e89c990120f24a31de13bc2c6 /sys-apps/grub
parentadded -xrender to configure, fixes #12918 (diff)
downloadhistorical-6fc25dc2387f72331e75fca2b8ddf47c93897d4a.tar.gz
historical-6fc25dc2387f72331e75fca2b8ddf47c93897d4a.tar.bz2
historical-6fc25dc2387f72331e75fca2b8ddf47c93897d4a.zip
providing virtual/bootloader
Diffstat (limited to 'sys-apps/grub')
-rw-r--r--sys-apps/grub/ChangeLog10
-rw-r--r--sys-apps/grub/grub-0.90-r7.ebuild11
-rw-r--r--sys-apps/grub/grub-0.91-r3.ebuild11
-rw-r--r--sys-apps/grub/grub-0.92-r1.ebuild4
-rw-r--r--sys-apps/grub/grub-0.92.ebuild7
5 files changed, 29 insertions, 14 deletions
diff --git a/sys-apps/grub/ChangeLog b/sys-apps/grub/ChangeLog
index 1315ba8851ef..09ba5b50b8dd 100644
--- a/sys-apps/grub/ChangeLog
+++ b/sys-apps/grub/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for sys-apps/grub
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/ChangeLog,v 1.13 2002/12/13 11:00:31 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/ChangeLog,v 1.14 2003/01/06 09:09:26 seemant Exp $
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*grub-0.92-r1 (02 Oct 2002)
+
+ 06 Jan 2002; Seemant Kulleen <seemant@gentoo.org> *.ebuild :
+ PROVIDE virtual/bootloader
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
02 Oct 2002; Donny Davies <woodchip@gentoo.org> :
Merge changes from Markus Krainer <markus-krainer@chello.at> to fix:
bootlogo; #6820. menu.lst was renamed to grub.conf; #6300.
diff --git a/sys-apps/grub/grub-0.90-r7.ebuild b/sys-apps/grub/grub-0.90-r7.ebuild
index 20f18e5c0e49..067bddadf752 100644
--- a/sys-apps/grub/grub-0.90-r7.ebuild
+++ b/sys-apps/grub/grub-0.90-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.90-r7.ebuild,v 1.8 2002/10/04 06:25:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.90-r7.ebuild,v 1.9 2003/01/06 09:09:26 seemant Exp $
inherit mount-boot
@@ -8,12 +8,15 @@ S=${WORKDIR}/${P}
DESCRIPTION="GNU GRUB boot loader"
SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/grub"
-KEYWORDS="x86 -ppc"
+
SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="x86 -ppc"
+
+DEPEND=">=sys-devel/binutils-2.9.1.0.23
+ >=sys-libs/ncurses-5.2-r2"
-DEPEND="virtual/glibc >=sys-devel/binutils-2.9.1.0.23 >=sys-libs/ncurses-5.2-r2"
-RDEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2"
+PROVIDE="virtual/bootloader"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/grub/grub-0.91-r3.ebuild b/sys-apps/grub/grub-0.91-r3.ebuild
index b5638b94d8ac..2a6a879facf7 100644
--- a/sys-apps/grub/grub-0.91-r3.ebuild
+++ b/sys-apps/grub/grub-0.91-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.91-r3.ebuild,v 1.9 2002/10/30 14:41:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.91-r3.ebuild,v 1.10 2003/01/06 09:09:26 seemant Exp $
inherit mount-boot
@@ -8,12 +8,15 @@ S=${WORKDIR}/${P}
DESCRIPTION="GNU GRUB boot loader"
SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/grub/"
-KEYWORDS="~x86 -ppc"
+
SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc"
+
+DEPEND=">=sys-devel/binutils-2.9.1.0.23
+ >=sys-libs/ncurses-5.2-r2"
-DEPEND="virtual/glibc >=sys-devel/binutils-2.9.1.0.23 >=sys-libs/ncurses-5.2-r2"
-RDEPEND="virtual/glibc >=sys-libs/ncurses-5.2-r2"
+PROVIDE="virtual/bootloader"
src_unpack() {
unpack ${A}
diff --git a/sys-apps/grub/grub-0.92-r1.ebuild b/sys-apps/grub/grub-0.92-r1.ebuild
index 70a8dea460ed..0d581cf6f525 100644
--- a/sys-apps/grub/grub-0.92-r1.ebuild
+++ b/sys-apps/grub/grub-0.92-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.92-r1.ebuild,v 1.5 2002/12/30 03:49:34 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.92-r1.ebuild,v 1.6 2003/01/06 09:09:26 seemant Exp $
inherit mount-boot
@@ -15,6 +15,8 @@ LICENSE="GPL-2"
DEPEND=">=sys-libs/ncurses-5.2-r5"
RDEPEND="virtual/glibc"
+PROVIDE="virtual/bootloader"
+
src_unpack() {
unpack ${A} || die
cd ${S} || die
diff --git a/sys-apps/grub/grub-0.92.ebuild b/sys-apps/grub/grub-0.92.ebuild
index 424e647863f6..82d7ac3decb2 100644
--- a/sys-apps/grub/grub-0.92.ebuild
+++ b/sys-apps/grub/grub-0.92.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.92.ebuild,v 1.11 2002/12/09 04:37:25 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.92.ebuild,v 1.12 2003/01/06 09:09:26 seemant Exp $
inherit mount-boot
@@ -8,12 +8,15 @@ S=${WORKDIR}/${P}
DESCRIPTION="GNU GRUB boot loader"
SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/grub/"
-KEYWORDS="~x86 -ppc -sparc "
+
SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc "
RDEPEND=">=sys-libs/ncurses-5.2-r5"
+PROVIDE="virtual/bootloader"
+
src_unpack() {
unpack ${A} || die
cd ${S} || die