summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-03-31 01:21:16 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-03-31 01:21:16 +0000
commitfeb0ca95c8a81c4aa42b5e516277751c9cb79fcb (patch)
tree616aa4caf332fa0b21dd61d2ef9b498ef73d7485 /sys-apps/dmapi
parentdep fixums (diff)
downloadhistorical-feb0ca95c8a81c4aa42b5e516277751c9cb79fcb.tar.gz
historical-feb0ca95c8a81c4aa42b5e516277751c9cb79fcb.tar.bz2
historical-feb0ca95c8a81c4aa42b5e516277751c9cb79fcb.zip
new set of xfs apps
Diffstat (limited to 'sys-apps/dmapi')
-rw-r--r--sys-apps/dmapi/dmapi-20020330.ebuild35
-rw-r--r--sys-apps/dmapi/files/digest-dmapi-200203301
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/dmapi/dmapi-20020330.ebuild b/sys-apps/dmapi/dmapi-20020330.ebuild
new file mode 100644
index 000000000000..1058e92d2163
--- /dev/null
+++ b/sys-apps/dmapi/dmapi-20020330.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmapi/dmapi-20020330.ebuild,v 1.1 2002/03/31 01:21:16 drobbins Exp $
+
+S=${WORKDIR}/cmd/${PN}
+DESCRIPTION="XFS data management API library"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/xfs-cmd-${PV}.tar.bz2"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make sys-apps/xfsprogs"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+}
diff --git a/sys-apps/dmapi/files/digest-dmapi-20020330 b/sys-apps/dmapi/files/digest-dmapi-20020330
new file mode 100644
index 000000000000..2993709f2f6e
--- /dev/null
+++ b/sys-apps/dmapi/files/digest-dmapi-20020330
@@ -0,0 +1 @@
+MD5 18bbd9b036cae38073bcaeef8b89ecf6 xfs-cmd-20020330.tar.bz2 1546532