summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-03 21:20:29 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-03 21:20:29 +0000
commitaf2653ebe8b64791af60f8a990b4f661959b167e (patch)
treef0602f369c8cfe4cfba348aab8f70f49b3097989 /sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
parentversion bump, for security fix in bug #49536 by gen2daniel <gen2daniel@gmx.net> (diff)
downloadhistorical-af2653ebe8b64791af60f8a990b4f661959b167e.tar.gz
historical-af2653ebe8b64791af60f8a990b4f661959b167e.tar.bz2
historical-af2653ebe8b64791af60f8a990b4f661959b167e.zip
arm KEYWORDS
Diffstat (limited to 'sys-apps/diffutils/diffutils-2.8.4-r4.ebuild')
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r4.ebuild28
1 files changed, 10 insertions, 18 deletions
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
index b8eb3dd684f2..be0621d54dec 100644
--- a/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
+++ b/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild
@@ -1,38 +1,30 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild,v 1.12 2004/03/02 16:45:46 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r4.ebuild,v 1.13 2004/05/03 21:20:29 vapier Exp $
-IUSE="nls build static"
-
-inherit eutils
-inherit flag-o-matic
+inherit eutils flag-o-matic
-# sdiff SIGSEGVs with this on gcc-3.2.1, so take it out
-# this fixes bug #13502
-filter-flags "-mpowerpc-gfxopt"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Tools to make diffs and compare files"
HOMEPAGE="http://www.gnu.org/software/diffutils/diffutils.html"
SRC_URI="ftp://alpha.gnu.org/gnu/diffutils/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc alpha hppa mips ~amd64 ia64 ppc64 s390"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc mips alpha arm hppa ~amd64 ia64 ppc64 s390"
+IUSE="nls build static"
DEPEND="virtual/glibc
>=sys-apps/portage-2.0.47-r10
>=sys-apps/sed-4
nls? ( sys-devel/gettext )
!build? ( sys-apps/texinfo sys-apps/help2man )"
-
RDEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
cd ${S}
- if [ -n "`use build`" ] ; then
+ if use build ; then
#disable texinfo building so we can remove the dep
sed -i -e 's:SUBDIRS = doc:SUBDIRS =:' \
Makefile.in || die "Makefile.in sed"
@@ -62,7 +54,7 @@ src_unpack() {
src_compile() {
econf --build=${CHOST} `use_enable nls` || die "econf"
- if [ "`use static`" ] ; then
+ if use static ; then
emake LDFLAGS=-static || die
else
emake || die
@@ -72,8 +64,8 @@ src_compile() {
src_install() {
einstall || die
- if [ -z "`use build`" ] ; then
- dodoc COPYING ChangeLog NEWS README
+ if ! use build ; then
+ dodoc ChangeLog NEWS README
else
rm -rf ${D}/usr/share/info
fi