summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-03-24 04:18:12 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-03-24 04:18:12 +0000
commitc2572929edf0556513ee3b01678ca0c632ece434 (patch)
tree2987864d9d872a074154221b97155c84ee6f9cd2 /sys-apps/checkpolicy/checkpolicy-1.30-r1.ebuild
parent(#127306) Digests changed between release candidates and final release for th... (diff)
downloadhistorical-c2572929edf0556513ee3b01678ca0c632ece434.tar.gz
historical-c2572929edf0556513ee3b01678ca0c632ece434.tar.bz2
historical-c2572929edf0556513ee3b01678ca0c632ece434.zip
Upstream bugfix for require blocks in base module.
Package-Manager: portage-2.1_pre6-r6
Diffstat (limited to 'sys-apps/checkpolicy/checkpolicy-1.30-r1.ebuild')
-rw-r--r--sys-apps/checkpolicy/checkpolicy-1.30-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/checkpolicy/checkpolicy-1.30-r1.ebuild b/sys-apps/checkpolicy/checkpolicy-1.30-r1.ebuild
new file mode 100644
index 000000000000..7017bfbd611a
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-1.30-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/checkpolicy-1.30-r1.ebuild,v 1.1 2006/03/24 04:18:12 pebenito Exp $
+
+IUSE=""
+
+inherit eutils
+
+SEMNG_VER="1.6"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="=sys-libs/libsemanage-${SEMNG_VER}*
+ sys-devel/flex
+ sys-devel/bison"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/checkpolicy-1.30.1.diff
+}
+
+src_compile() {
+ cd ${S}
+ emake YACC="bison -y" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}