summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-03-30 05:50:01 +0000
committerMike Frysinger <vapier@gentoo.org>2007-03-30 05:50:01 +0000
commitfa1f7e6851133e9021fa66d64a3559f72e17a9fe (patch)
treefd4e6cb05153d3fd8a86ddc8b811482995220991 /sys-apps/busybox
parentNew upstream release, this is a release candidate, the final version should b... (diff)
downloadhistorical-fa1f7e6851133e9021fa66d64a3559f72e17a9fe.tar.gz
historical-fa1f7e6851133e9021fa66d64a3559f72e17a9fe.tar.bz2
historical-fa1f7e6851133e9021fa66d64a3559f72e17a9fe.zip
make sure selinux libs come last in linking #160879 by Peter Hjalmarsson
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/files/1.4.0/selinux-link.patch14
1 files changed, 13 insertions, 1 deletions
diff --git a/sys-apps/busybox/files/1.4.0/selinux-link.patch b/sys-apps/busybox/files/1.4.0/selinux-link.patch
index b2e69e4ac025..ee5c645861de 100644
--- a/sys-apps/busybox/files/1.4.0/selinux-link.patch
+++ b/sys-apps/busybox/files/1.4.0/selinux-link.patch
@@ -1,3 +1,15 @@
+--- busybox-1.4.2/Makefile
++++ busybox-1.4.2/Makefile
+@@ -564,7 +564,8 @@
+ cmd_busybox__ ?= $(srctree)/scripts/trylink $(CC) $(LDFLAGS) \
+ -o $@ \
+ -Wl,--warn-common -Wl,--sort-common -Wl,--gc-sections \
+- -Wl,--start-group $(busybox-all) -Wl,--end-group
++ -Wl,--start-group $(busybox-all) -Wl,--end-group \
++ $(LDLIBS)
+
+ # Generate System.map
+ quiet_cmd_sysmap = SYSMAP
--- busybox-1.4.2/Makefile.flags
+++ busybox-1.4.2/Makefile.flags
@@ -28,4 +28,8 @@
@@ -6,6 +18,6 @@
endif
+
+ifeq ($(CONFIG_SELINUX),y)
-+LDFLAGS += -lselinux -lsepol
++LDLIBS += -lselinux -lsepol
+endif
#LDFLAGS += -nostdlib