summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-23 03:24:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-23 03:24:53 +0000
commit0c2aea11581f371132e47fddc6e361581592d39b (patch)
treebedfd8c591ffecce4c3588bfe2dfa5bf41c9234a /sci-physics
parentVersion bump (diff)
downloadhistorical-0c2aea11581f371132e47fddc6e361581592d39b.tar.gz
historical-0c2aea11581f371132e47fddc6e361581592d39b.tar.bz2
historical-0c2aea11581f371132e47fddc6e361581592d39b.zip
Initial import
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/heppdt/ChangeLog10
-rw-r--r--sci-physics/heppdt/Manifest14
-rw-r--r--sci-physics/heppdt/heppdt-3.04.01.ebuild42
-rw-r--r--sci-physics/heppdt/metadata.xml14
4 files changed, 80 insertions, 0 deletions
diff --git a/sci-physics/heppdt/ChangeLog b/sci-physics/heppdt/ChangeLog
new file mode 100644
index 000000000000..66943f5eac3f
--- /dev/null
+++ b/sci-physics/heppdt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-physics/heppdt
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/heppdt/ChangeLog,v 1.1 2010/03/23 03:24:53 bicatali Exp $
+
+*heppdt-3.04.01 (23 Mar 2010)
+
+ 23 Mar 2010; SĂ©bastien Fabbro <bicatali@gentoo.org>
+ +heppdt-3.04.01.ebuild, +metadata.xml:
+ Initial import
+
diff --git a/sci-physics/heppdt/Manifest b/sci-physics/heppdt/Manifest
new file mode 100644
index 000000000000..ff89cacd1f0d
--- /dev/null
+++ b/sci-physics/heppdt/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST HepPDT-3.04.01.tar.gz 1851879 RMD160 7e2586aeaf3cdd4f6511225436ceb55d283f4c43 SHA1 ab717f5a6a23e91d263defd5e91eb06c19e1793c SHA256 2c1c39eb91295d3ded69e0d3f1a38b1cb55bc3f0cde37b725ffd5d722f63c0f6
+EBUILD heppdt-3.04.01.ebuild 1046 RMD160 1c6622f59683552ea5c122a3609c19e4286c742e SHA1 ab2b2897fff4abdd7dba5ffed4f3748adf7279c2 SHA256 5dca4128fd773d1fdfa7ef2705622c3e43ccafbe9464dd265ee3cad9a1981d49
+MISC ChangeLog 356 RMD160 e1936acb1c0ba72fabdb4226d2ccfd02edae5a6b SHA1 18261102e8d3b6aad5f2cd1d8ef0faca0c854cbe SHA256 0e3c94798c34058b102dfdd128ecc25173e7de8d8efb58653b286fddae097a44
+MISC metadata.xml 630 RMD160 bba8a1923da84e6b2f0e6c8e01338666f7a356b3 SHA1 cb4e211f25a8754d42a86e0a97d7958b9841483a SHA256 539c75262c90eb9361fa6d92a2cbe019fd02c1da6cf40d69c604513cbeb5da20
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.14 (GNU/Linux)
+
+iEYEARECAAYFAkuoNI8ACgkQ1ycZbhPLE2CpYACgrKxmJxSYGDOV9n0/FgZFr/Fd
+qRsAoIrFXF3ONmgU+RWAeqkVtjvd9Rdx
+=IkAR
+-----END PGP SIGNATURE-----
diff --git a/sci-physics/heppdt/heppdt-3.04.01.ebuild b/sci-physics/heppdt/heppdt-3.04.01.ebuild
new file mode 100644
index 000000000000..197a3b54ddfd
--- /dev/null
+++ b/sci-physics/heppdt/heppdt-3.04.01.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/heppdt/heppdt-3.04.01.ebuild,v 1.1 2010/03/23 03:24:53 bicatali Exp $
+
+EAPI=2
+inherit autotools
+
+MYP=HepPDT-${PV}
+
+DESCRIPTION="Data about each particle from the Review of Particle Properties"
+HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepPDT/"
+SRC_URI="${HOMEPAGE}/download/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # respect user flags
+ sed -i \
+ -e '/AC_SUBST(AM_CXXFLAGS)/d' \
+ configure.ac || die
+ # directories
+ sed -i \
+ -e 's:$(prefix)/data:$(datadir)/${PN}:g' \
+ data/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog
+ use doc && mv "${D}"usr/doc/* "${D}"usr/share/doc/${PF}/
+ use examples && mv "${D}"usr/examples "${D}"usr/share/doc/${PF}/
+ rm -rf "${D}"usr/{doc,examples}
+}
diff --git a/sci-physics/heppdt/metadata.xml b/sci-physics/heppdt/metadata.xml
new file mode 100644
index 000000000000..89a8cc95903e
--- /dev/null
+++ b/sci-physics/heppdt/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ HepPDT contains the fixed data about each particle type. In other
+ words, it contains the data that can be found in the Review of
+ Particle Properties.
+ This data is conceptually split into particle information (e.g. mass)
+ and decay information. HepPDT provides a simple set of particle data
+ classes. Particle ID translation methods are in a separate HepPID
+ library, which is distributed as part of HepPDT.
+</longdescription>
+</pkgmetadata>