summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-20 12:52:43 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-20 12:52:43 +0000
commitd705a770281a9417387c82c95a2aae1a101d7055 (patch)
tree6d8feb8e8d0e19b28f0e860eb4e2764fd9016ff9 /sci-mathematics/drgeo/drgeo-1.1.0.ebuild
parentAdd a minimum version on media-libs/speex so we can drop the built_with_use c... (diff)
downloadhistorical-d705a770281a9417387c82c95a2aae1a101d7055.tar.gz
historical-d705a770281a9417387c82c95a2aae1a101d7055.tar.bz2
historical-d705a770281a9417387c82c95a2aae1a101d7055.zip
Migrate to EAPI 2 in order to nuke built_with_use.
Package-Manager: portage-2.2_rc40/cvs/Linux i686
Diffstat (limited to 'sci-mathematics/drgeo/drgeo-1.1.0.ebuild')
-rw-r--r--sci-mathematics/drgeo/drgeo-1.1.0.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/sci-mathematics/drgeo/drgeo-1.1.0.ebuild b/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
index 3b7df92e9faf..e2aa560c273f 100644
--- a/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
+++ b/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/drgeo-1.1.0.ebuild,v 1.5 2008/01/08 00:37:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/drgeo/drgeo-1.1.0.ebuild,v 1.6 2009/09/20 12:52:43 betelgeuse Exp $
+
+EAPI="2"
inherit eutils
@@ -21,21 +23,16 @@ IUSE="nls"
RDEPEND=">=x11-libs/gtk+-2
>=gnome-base/libglade-2
>=dev-libs/libxml2-2
- >=dev-scheme/guile-1.4"
+ || (
+ >=dev-scheme/guile-1.8[deprecated]
+ =dev-scheme/guile-1.6*
+ )"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- if has_version =dev-scheme/guile-1.8*; then
- built_with_use dev-scheme/guile deprecated \
- || die "guile must be built with deprecated use flag"
- fi
-}
-
-src_compile() {
- econf || die "econf failed."
- emake || die "emake failed."
+src_configure() {
+ default
# Can't make the documentation as it depends on Hyperlatex which isn't
# yet in portage. Fortunately HTML is already compiled for us in the
# tarball and so can be installed. Just create the make install target.