summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-04 15:30:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-04 15:30:17 +0000
commitcdf14bfb8b57a893a22870b9fb8c887910049754 (patch)
tree82cf000ca07dda15074434ece04ab61e2ea4b649 /sci-libs
parentinitial commit based on ebuild of Alexander Berntsen (diff)
downloadhistorical-cdf14bfb8b57a893a22870b9fb8c887910049754.tar.gz
historical-cdf14bfb8b57a893a22870b9fb8c887910049754.tar.bz2
historical-cdf14bfb8b57a893a22870b9fb8c887910049754.zip
keyword amd64-linux, x86-linux
Package-Manager: portage-2.2.01.20796-prefix/cvs/Linux x86_64
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vecmath-objectclub/ChangeLog9
-rw-r--r--sci-libs/vecmath-objectclub/metadata.xml11
-rw-r--r--sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild22
3 files changed, 27 insertions, 15 deletions
diff --git a/sci-libs/vecmath-objectclub/ChangeLog b/sci-libs/vecmath-objectclub/ChangeLog
index a84910cba119..0ecadc793aee 100644
--- a/sci-libs/vecmath-objectclub/ChangeLog
+++ b/sci-libs/vecmath-objectclub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/vecmath-objectclub
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vecmath-objectclub/ChangeLog,v 1.2 2007/06/21 23:11:48 caster Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vecmath-objectclub/ChangeLog,v 1.3 2012/08/04 15:30:17 bicatali Exp $
+
+ 04 Aug 2012; SĂ©bastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ vecmath-objectclub-1.14.ebuild:
+ keyword amd64-linux, x86-linux
21 Jun 2007; Vlastimil Babka <caster@gentoo.org>
vecmath-objectclub-1.14.ebuild:
@@ -11,4 +15,3 @@
22 May 2007; Jeff Gardner <je_fro@gentoo.org> +metadata.xml,
+vecmath-objectclub-1.14.ebuild:
Initial import.
-
diff --git a/sci-libs/vecmath-objectclub/metadata.xml b/sci-libs/vecmath-objectclub/metadata.xml
index 7ea3102ac9b4..1be81e8d9011 100644
--- a/sci-libs/vecmath-objectclub/metadata.xml
+++ b/sci-libs/vecmath-objectclub/metadata.xml
@@ -3,10 +3,17 @@
<pkgmetadata>
<herd>sci</herd>
<maintainer>
-<email>je_fro@gentoo.org</email>
-<name>Jeff Gardner</name>
+ <email>je_fro@gentoo.org</email>
+ <name>Jeff Gardner</name>
</maintainer>
<longdescription lang="en">
+ This is unofficial implementation(java source code) of the
+ javax.vecmath package specified in the Java(TM) 3D API 1.2
+ The package includes classes for 3-space vector/point, 4-space vector,
+ 4x4, 3x3 matrix, quaternion, axis-angle combination and etc. which are
+ often utilized for computer graphics mathematics. Most of the classes
+ have single and double precision versions. Generic matrices' LU and SV
+ decomposition are also there.
</longdescription>
</pkgmetadata>
diff --git a/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild b/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild
index 7cfefb260d13..7acf100e2927 100644
--- a/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild
+++ b/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild
@@ -1,17 +1,20 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild,v 1.2 2007/06/21 23:11:48 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vecmath-objectclub/vecmath-objectclub-1.14.ebuild,v 1.3 2012/08/04 15:30:17 bicatali Exp $
+
+EAPI=4
inherit java-pkg-2
MY_PN="${PN/-objectclub/1.2}"
-DESCRIPTION=" Unofficial free implementation of Sun javax.vecmath by Kenji Hiranabe"
+
+DESCRIPTION="Unofficial free implementation of Sun javax.vecmath by Kenji Hiranabe"
HOMEPAGE="http://www.objectclub.jp/download/vecmath_e"
SRC_URI="http://www.objectclub.jp/download/files/vecmath/${MY_PN}-${PV}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
DEPEND=">=virtual/jdk-1.4"
@@ -19,20 +22,19 @@ RDEPEND=">=virtual/jre-1.4"
S="${WORKDIR}/${MY_PN}-${PV}"
-src_unpack() {
- unpack ${A}
- mkdir "${S}/classes"
+src_prepare() {
+ mkdir classes
}
src_compile() {
find javax/ -name "*.java" > "${T}/src.list"
ejavac -d "${S}/classes" "@${T}/src.list"
- cd "${S}/classes"
- jar -cf "${S}/${PN}.jar" * || die "failed to create jar"
+ cd classes
+ jar -cf "${S}"/${PN}.jar * || die "failed to create jar"
}
src_install() {
- java-pkg_dojar "${S}/${PN}.jar"
+ java-pkg_dojar ${PN}.jar
dodoc README
}