summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-13 12:51:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-13 12:51:24 +0000
commitb1c92c158748c68610e9b327239fe9723b53b523 (patch)
tree38e064a8a1622ca8915cdef5a811389f339ee9e0 /sci-libs/mpir/mpir-2.1.3.ebuild
parentVersion Bump (diff)
downloadhistorical-b1c92c158748c68610e9b327239fe9723b53b523.tar.gz
historical-b1c92c158748c68610e9b327239fe9723b53b523.tar.bz2
historical-b1c92c158748c68610e9b327239fe9723b53b523.zip
Some QA
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'sci-libs/mpir/mpir-2.1.3.ebuild')
-rw-r--r--sci-libs/mpir/mpir-2.1.3.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sci-libs/mpir/mpir-2.1.3.ebuild b/sci-libs/mpir/mpir-2.1.3.ebuild
index 47530eb66cd8..56e7d8f249bd 100644
--- a/sci-libs/mpir/mpir-2.1.3.ebuild
+++ b/sci-libs/mpir/mpir-2.1.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/mpir-2.1.3.ebuild,v 1.1 2010/11/12 13:15:46 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/mpir-2.1.3.ebuild,v 1.2 2010/11/13 12:51:24 jlec Exp $
EAPI="3"
inherit eutils autotools
-DESCRIPTION="library for arbitrary precision integer arithmetic derived from version 4.2.1 of gmp"
+DESCRIPTION="Library for arbitrary precision integer arithmetic derived from version 4.2.1 of gmp"
HOMEPAGE="http://www.mpir.org/"
SRC_URI="http://www.mpir.org/${P}.tar.gz"
@@ -20,8 +20,9 @@ DEPEND="x86? ( dev-lang/yasm )
RDEPEND=""
src_prepare(){
- epatch "${FILESDIR}/${PN}-2.0.0-yasm.patch"
- epatch "${FILESDIR}/${PN}-1.3.0-ABI-multilib.patch"
+ epatch \
+ "${FILESDIR}/${PN}-2.0.0-yasm.patch" \
+ "${FILESDIR}/${PN}-1.3.0-ABI-multilib.patch"
# In the same way there was QA regarding executable stacks
# with GMP we have some here as well. We cannot apply the
# GMP solution as yasm is used, at least on x86/amd64.
@@ -55,11 +56,10 @@ src_configure() {
# Place mpir in profiles/arch/$arch/package.use.mask when making it available on $arch.
econf \
$(use_enable cxx) \
- $(use_enable cpudetection fat) \
- || "econf failed"
+ $(use_enable cpudetection fat)
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog README NEWS
+ dodoc ChangeLog README NEWS || die
}