summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-10-10 17:53:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-10-10 17:53:49 +0000
commit42163b33faaad882ca4dbfa191281d474feff85d (patch)
tree54576b77a6fd798654695521852ee0bcdcbdc2a6 /sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
parent* New version for GNOME 2.24. Mostly bug fixes and performance improvments. (diff)
downloadhistorical-42163b33faaad882ca4dbfa191281d474feff85d.tar.gz
historical-42163b33faaad882ca4dbfa191281d474feff85d.tar.bz2
historical-42163b33faaad882ca4dbfa191281d474feff85d.zip
Fixed a syntax error in the minimal flag, and added blas configuration in the supernodal mode
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'sci-libs/cholmod/cholmod-1.6.0-r1.ebuild')
-rw-r--r--sci-libs/cholmod/cholmod-1.6.0-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild b/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
index fd104791682f..b029703eea02 100644
--- a/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
+++ b/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild,v 1.6 2008/05/22 01:26:28 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cholmod/cholmod-1.6.0-r1.ebuild,v 1.7 2008/10/10 17:53:49 bicatali Exp $
inherit autotools eutils
@@ -53,18 +53,22 @@ src_unpack() {
s:\(#define\) \(CHOLMOD_CONFIG_H\)\n:\1 \2\n\1 NPARTITION 1\n:}' \
Include/cholmod_config.h
fi
-
eautoreconf
}
src_compile() {
local lapack_libs=no
- use supernodal && lapack_libs=$(pkg-config --libs lapack)
+ local blas_libs=no
+ if use supernodal; then
+ blas_libs=$(pkg-config --libs blas)
+ lapack_libs=$(pkg-config --libs lapack)
+ fi
econf \
+ --with-blas="${blas_libs}" \
--with-lapack="${lapack_libs}" \
$(use_enable supernodal mod-supernodal) \
$(use_enable !minimal mod-modify) \
- $(use_enable !minimal mod-matrix-ops) \
+ $(use_enable !minimal mod-matrixops) \
$(use_enable metis mod-partition) \
|| die "econf failed"
emake || die "emake failed"