summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2014-09-27 07:49:12 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2014-09-27 07:49:12 +0000
commit60d2eec01524f39caf6b88792503b3bf5541a1ce (patch)
treea641b672017bb0a120ea3a5dca5dad2d742906ae /sci-electronics/xnec2c/xnec2c-3.0.ebuild
parentforce configure to use bash due to bashisms (x=${x/foo/}) (diff)
downloadhistorical-60d2eec01524f39caf6b88792503b3bf5541a1ce.tar.gz
historical-60d2eec01524f39caf6b88792503b3bf5541a1ce.tar.bz2
historical-60d2eec01524f39caf6b88792503b3bf5541a1ce.zip
Version bump
Package-Manager: portage-2.2.12/cvs/Linux x86_64 Manifest-Sign-Key: 0x762053D5
Diffstat (limited to 'sci-electronics/xnec2c/xnec2c-3.0.ebuild')
-rw-r--r--sci-electronics/xnec2c/xnec2c-3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-electronics/xnec2c/xnec2c-3.0.ebuild b/sci-electronics/xnec2c/xnec2c-3.0.ebuild
new file mode 100644
index 000000000000..5bf34ac48562
--- /dev/null
+++ b/sci-electronics/xnec2c/xnec2c-3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/xnec2c-3.0.ebuild,v 1.1 2014/09/27 07:48:59 tomjbe Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A GTK+ graphical interactive version of nec2c"
+HOMEPAGE="http://www.qsl.net/5b4az/pages/nec2.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/nec2/xnec2c/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ glib-gettextize --force --copy || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS README doc/*.txt
+ use doc && dohtml -r doc/*.html doc/images
+ insinto /usr/share/doc/${PF}/examples
+ use examples && doins examples/*
+}