summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 12:54:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 12:54:00 +0000
commit3bbf963d283a9d7db1a90d1eaad3a8a654ff911e (patch)
tree03b28f0aacd6efbd91670a4320e08a164aa39c2f /sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild
parentamd64 stable wrt #298979 (diff)
downloadhistorical-3bbf963d283a9d7db1a90d1eaad3a8a654ff911e.tar.gz
historical-3bbf963d283a9d7db1a90d1eaad3a8a654ff911e.tar.bz2
historical-3bbf963d283a9d7db1a90d1eaad3a8a654ff911e.zip
New addition of NMR software
Package-Manager: portage-2.2_rc65/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild')
-rw-r--r--sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild b/sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild
new file mode 100644
index 000000000000..9adee0888b1b
--- /dev/null
+++ b/sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/talos+/talos+-1.2009.1013.14.ebuild,v 1.1 2010/03/07 12:54:00 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="A Hybrid method for predicting protein backbone torsion angles from NMR CS"
+HOMEPAGE="http://spin.niddk.nih.gov/bax/software/TALOS+/index.html"
+SRC_URI="http://spin.niddk.nih.gov/bax/software/TALOS+/talos+.tar.Z -> ${P}.tar.Z"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="dev-lang/tcl"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/rama+.patch
+}
+
+src_install() {
+ sed \
+ -e "s:DIR_HERE:${EPREFIX}/opt/${PN}/:g" \
+ -i *+
+
+ insinto /opt/${PN}/
+ doins -r tab rama.{dat,gif} || die
+
+ exeinto /opt/${PN}/bin
+ newexe bin/TALOS+.linux TALOS+ || die
+ doexe rama+.tcl || die
+
+ dobin bmrb2talos.com talos2dyana.com talos2xplor.com talos+ rama+ || die
+
+ dodoc README || die
+}