summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-24 17:00:58 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-24 17:00:58 +0000
commitb8c19e0030aa1cf866ccaa900a2e25a5c04a85c1 (patch)
treea3b26f1cb0e52140a754313c17d63a4785a8fc73 /sci-chemistry/pymol/pymol-0.97.ebuild
parentMoving to sci-chemistry/pymol (diff)
downloadhistorical-b8c19e0030aa1cf866ccaa900a2e25a5c04a85c1.tar.gz
historical-b8c19e0030aa1cf866ccaa900a2e25a5c04a85c1.tar.bz2
historical-b8c19e0030aa1cf866ccaa900a2e25a5c04a85c1.zip
Moved from app-sci/pymol to sci-chemistry/pymol.
Diffstat (limited to 'sci-chemistry/pymol/pymol-0.97.ebuild')
-rw-r--r--sci-chemistry/pymol/pymol-0.97.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/pymol/pymol-0.97.ebuild b/sci-chemistry/pymol/pymol-0.97.ebuild
new file mode 100644
index 000000000000..9b0c8093537e
--- /dev/null
+++ b/sci-chemistry/pymol/pymol-0.97.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-0.97.ebuild,v 1.1 2004/12/24 17:00:58 ribosome Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A Python-extensible molecular graphics system."
+HOMEPAGE="http://pymol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pymol/${PN}-${PV/./_}-src.tgz"
+
+LICENSE="PSF-2.2"
+IUSE=""
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-lang/python
+ dev-python/pmw
+ dev-python/numeric
+ dev-lang/tk
+ media-libs/libpng
+ sys-libs/zlib
+ media-libs/glut"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Turn off splash screen. Please do make a project contribution
+ # if you are able though.
+ [[ -n "$WANT_NOSPLASH" ]] && epatch ${FILESDIR}/nosplash-gentoo.patch
+}
+
+src_install() {
+ distutils_src_install
+ cd ${S}
+ PYTHONPATH=$(find ${D}/usr/lib -type d -name site-packages) ${python} setup2.py
+
+ local sedexp="s:${D%/}::g"
+ sed -e ${sedexp} pymol.com > pymol
+ exeinto /usr/bin
+ doexe pymol
+ dodoc DEVELOPERS CHANGES
+ #install examples
+ mv examples ${D}/usr/share/doc/${PF}
+}