summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-12-03 04:25:44 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-12-03 04:25:44 +0000
commit90f5c32c5a1e36dfab286254a5c503482d8d0920 (patch)
treea0125fcfc63e97a6e8a9f599757daebdcef503d6 /sci-chemistry/gopenmol
parentpatch from nelchael for draft/templates folder (diff)
downloadhistorical-90f5c32c5a1e36dfab286254a5c503482d8d0920.tar.gz
historical-90f5c32c5a1e36dfab286254a5c503482d8d0920.tar.bz2
historical-90f5c32c5a1e36dfab286254a5c503482d8d0920.zip
(#53333) New molecular graphics package for visualizing and analyzing structures. Based on ebuild by Dirk-Jan Heijs <heijs@phys.rug.nl>, with updates and fixes by me.
Package-Manager: portage-2.0.53
Diffstat (limited to 'sci-chemistry/gopenmol')
-rw-r--r--sci-chemistry/gopenmol/ChangeLog13
-rw-r--r--sci-chemistry/gopenmol/Manifest5
-rw-r--r--sci-chemistry/gopenmol/files/3.00-include-config-for-plugins.patch11
-rw-r--r--sci-chemistry/gopenmol/files/digest-gopenmol-3.001
-rw-r--r--sci-chemistry/gopenmol/gopenmol-3.00.ebuild63
-rw-r--r--sci-chemistry/gopenmol/metadata.xml9
6 files changed, 102 insertions, 0 deletions
diff --git a/sci-chemistry/gopenmol/ChangeLog b/sci-chemistry/gopenmol/ChangeLog
new file mode 100644
index 000000000000..f0c980b08a1a
--- /dev/null
+++ b/sci-chemistry/gopenmol/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-chemistry/gopenmol
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/ChangeLog,v 1.1 2005/12/03 04:25:44 spyderous Exp $
+
+*gopenmol-3.00 (03 Dec 2005)
+
+ 03 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/3.00-include-config-for-plugins.patch, +metadata.xml,
+ +gopenmol-3.00.ebuild:
+ (#53333) New molecular graphics package for visualizing and analyzing
+ structures. Based on ebuild by Dirk-Jan Heijs <heijs@phys.rug.nl>, with
+ updates and fixes by me.
+
diff --git a/sci-chemistry/gopenmol/Manifest b/sci-chemistry/gopenmol/Manifest
new file mode 100644
index 000000000000..f2bcb25649a9
--- /dev/null
+++ b/sci-chemistry/gopenmol/Manifest
@@ -0,0 +1,5 @@
+MD5 f96c68ee6c944a0f79724854aea84b3b ChangeLog 567
+MD5 804493c5ad07a3849352770e90549266 files/3.00-include-config-for-plugins.patch 383
+MD5 396f13264bc2c98dcc3782af54bae392 files/digest-gopenmol-3.00 73
+MD5 4493524a588dbb204c34e36dbadf00de gopenmol-3.00.ebuild 1240
+MD5 af1bfbb0777267a03e889b08173f2757 metadata.xml 248
diff --git a/sci-chemistry/gopenmol/files/3.00-include-config-for-plugins.patch b/sci-chemistry/gopenmol/files/3.00-include-config-for-plugins.patch
new file mode 100644
index 000000000000..a8602d07a03e
--- /dev/null
+++ b/sci-chemistry/gopenmol/files/3.00-include-config-for-plugins.patch
@@ -0,0 +1,11 @@
+--- gOpenMol-3.00.orig/src/plugins/Makefile 2005-12-02 19:38:08.000000000 -0800
++++ gOpenMol-3.00/src/plugins/Makefile 2005-12-02 19:37:29.000000000 -0800
+@@ -8,6 +8,8 @@
+ # Coded by: Eero Häkkinen
+ ##############################################################################
+
++include config.mk
++
+ build-all: build FORCE ;
+
+ all install install-local uninstall: FORCE
diff --git a/sci-chemistry/gopenmol/files/digest-gopenmol-3.00 b/sci-chemistry/gopenmol/files/digest-gopenmol-3.00
new file mode 100644
index 000000000000..8669525a5f7b
--- /dev/null
+++ b/sci-chemistry/gopenmol/files/digest-gopenmol-3.00
@@ -0,0 +1 @@
+MD5 4e12ee6680c093a3bf056dde1d28fea2 gopenmol-3.00-linux.tar.gz 29615195
diff --git a/sci-chemistry/gopenmol/gopenmol-3.00.ebuild b/sci-chemistry/gopenmol/gopenmol-3.00.ebuild
new file mode 100644
index 000000000000..ca6664fc640e
--- /dev/null
+++ b/sci-chemistry/gopenmol/gopenmol-3.00.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gopenmol/gopenmol-3.00.ebuild,v 1.1 2005/12/03 04:25:44 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="gOpenMol is a tool for the visualization and analysis of molecular structures"
+HOMEPAGE="http://www.csc.fi/gopenmol"
+SRC_URI="${HOMEPAGE}/distribute/${P}-linux.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/tcl-8.4*
+ =dev-lang/tk-8.4*
+ dev-tcltk/bwidget
+ virtual/opengl
+ virtual/glut
+ media-libs/jpeg
+ dev-lang/python
+ || ( (
+ x11-libs/libXmu
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXi
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/gOpenMol-${PV}/src"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-include-config-for-plugins.patch
+}
+
+src_compile() {
+ econf || die "./configure failed"
+
+ emake || die "emake failed"
+
+ # Plugins are not build by default
+ cd ${S}/plugins
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ cd ${S}/plugins
+ einstall || die
+
+ dosed /usr/bin/rungOpenMol
+}
+
+pkg_postinst() {
+ einfo "Run gOpenMol using the rungOpenMol script."
+}
diff --git a/sci-chemistry/gopenmol/metadata.xml b/sci-chemistry/gopenmol/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-chemistry/gopenmol/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>