summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-02 08:56:56 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-02 08:56:56 +0000
commit0f2782b18fbfc216b6bb2fb24a7d2709a9b21559 (patch)
treef5bd465a257e614c4576b0d140440167d914ba43 /sci-chemistry/apbs/apbs-1.3.ebuild
parentVersion bump thanks to Justin Lecher (bug #373737). (diff)
downloadhistorical-0f2782b18fbfc216b6bb2fb24a7d2709a9b21559.tar.gz
historical-0f2782b18fbfc216b6bb2fb24a7d2709a9b21559.tar.bz2
historical-0f2782b18fbfc216b6bb2fb24a7d2709a9b21559.zip
Use pkg-config to detect mmdb and lapack libs
Package-Manager: portage-2.2.0_alpha43/cvs/Linux x86_64
Diffstat (limited to 'sci-chemistry/apbs/apbs-1.3.ebuild')
-rw-r--r--sci-chemistry/apbs/apbs-1.3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-chemistry/apbs/apbs-1.3.ebuild b/sci-chemistry/apbs/apbs-1.3.ebuild
index a35ae022f15d..5939b16a69f2 100644
--- a/sci-chemistry/apbs/apbs-1.3.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.7 2011/06/21 16:07:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.8 2011/07/02 08:56:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic fortran-2 python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -105,7 +105,7 @@ src_configure() {
econf \
--disable-maloc-rebuild \
--enable-shared \
- --with-blas=-lblas \
+ --with-blas="$(pkg-config --libs blas)" \
$(use_enable openmp) \
$(use_enable python) \
$(use_enable tools) \