summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-26 15:34:44 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-26 15:34:44 +0000
commit61e63e1bd130cc31061574a2698bb2d8453734a7 (patch)
tree539d1120da03d28302665ee4060d878d18857fc7 /sci-astronomy
parentRemove older ebuild (diff)
downloadhistorical-61e63e1bd130cc31061574a2698bb2d8453734a7.tar.gz
historical-61e63e1bd130cc31061574a2698bb2d8453734a7.tar.bz2
historical-61e63e1bd130cc31061574a2698bb2d8453734a7.zip
Improving Python-related code wrt bug 316163
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/ChangeLog10
-rw-r--r--sci-astronomy/pyephem/Manifest4
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.3.4.ebuild38
3 files changed, 40 insertions, 12 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
index 191efa0b151e..28346b5e8ce7 100644
--- a/sci-astronomy/pyephem/ChangeLog
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/pyephem
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.9 2009/07/26 13:45:52 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.10 2010/05/26 15:34:44 xarthisius Exp $
+
+ 26 May 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ pyephem-3.7.3.4.ebuild:
+ Improving Python-related code wrt bug 316163. Thanks Arfrever for
+ reporting.
+ Adding doc flag and sphinx dependency.
*pyephem-3.7.3.4 (26 Jul 2009)
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
index d73983066c83..c2c62217ce53 100644
--- a/sci-astronomy/pyephem/Manifest
+++ b/sci-astronomy/pyephem/Manifest
@@ -1,4 +1,4 @@
DIST pyephem-3.7.3.4.tar.gz 704097 RMD160 798b79bebf094bd3d5b22a598281c564e974e89e SHA1 d1be94b2f0314a6ec572787c6d1b39ffbbb8ea5c SHA256 d6d2491c4b2d7d123f35bfda5b6ddd20afca832dfc4e10f3b2499bbd4c5e4587
-EBUILD pyephem-3.7.3.4.ebuild 904 RMD160 4b139dd2822e5aadffbd6f39df80e5e42db062d3 SHA1 05752298d3e67758df59b472d632b27e40dac86e SHA256 9546abf6b5a5b01867d9d684883f7fbea32bec4474b29e93c7f01952dc64115b
-MISC ChangeLog 1712 RMD160 edbd67bed9bb4717cab9f5c7354320162bf676dc SHA1 0f84d652328d217e176087df1aa8464f820ee8c3 SHA256 433a6631d407c9ba9651b3c8d879ef7592175a879441af8284d13cf750fe452d
+EBUILD pyephem-3.7.3.4.ebuild 1259 RMD160 cfed6de23577775785e78dad3631a449370d1334 SHA1 10210d5b7fe385fa4d567f67774902686b171da5 SHA256 75f94c088dbf0f244abf2ee77c248aa44cfe8045fd6250ce1a69e39f4c35b033
+MISC ChangeLog 1918 RMD160 8e1e7a848366211c7f07e9e7e4046403bc7f21b3 SHA1 0721b817b2a3f90069f8a4ed288f7ca2a0e9d507 SHA256 c1d7f37aa6d1df1287455acc88118dd0d6a295f9f092c202f31795d07980e8b7
MISC metadata.xml 770 RMD160 0e05a60bb61d77ebce7c2d520ebc802adb570e2f SHA1 e9ffd03d0916e57bdd0f162aff7d8af15dd2598d SHA256 080408a235520efbe6fce1b0d1276c8fb1cf461e38c498da38bf3ecc666aa8f0
diff --git a/sci-astronomy/pyephem/pyephem-3.7.3.4.ebuild b/sci-astronomy/pyephem/pyephem-3.7.3.4.ebuild
index fbca41167ed4..6daffb4d3afe 100644
--- a/sci-astronomy/pyephem/pyephem-3.7.3.4.ebuild
+++ b/sci-astronomy/pyephem/pyephem-3.7.3.4.ebuild
@@ -1,8 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.3.4.ebuild,v 1.1 2009/07/26 13:45:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.3.4.ebuild,v 1.2 2010/05/26 15:34:44 xarthisius Exp $
-inherit distutils
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
DESCRIPTION="Astronomical routines for the python programming language"
LICENSE="LGPL-3"
@@ -11,17 +16,34 @@ SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="doc"
+RDEPEND=""
+DEPEND="doc? ( dev-python/sphinx )"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+src_prepare() {
+ # don't install rst files
+ sed -i -e "s:'doc/\*\.rst',::" "${S}"/setup.py || die
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd src/ephem/doc
+ PYTHONPATH=../../.. emake html || die "Building of documentation failed"
+ fi
+}
src_test() {
# remove a buggy test (it's a doc test), check next version.
mv src/ephem/tests/test_rst.py{,orig}
- PYTHONPATH=$(dir -d build/lib*) ${python} setup.py test || die "tests failed"
+ distutils_src_test
}
src_install() {
distutils_src_install
- insinto /usr/share/doc/${PF}
- mv "${D}"/usr/lib*/${python}*/site-packages/ephem/doc \
- "${D}"/usr/share/doc/${PF}/html || die "Failed to install doc"
+ if use doc; then
+ dohtml -r src/ephem/doc/.build/html/* || die "Installation of documentation failed"
+ fi
}