summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-19 18:13:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-19 18:13:27 +0000
commitf9bdb272751e96455e260a80861461e05b759f75 (patch)
tree487759ef4c2ca7d5bc634af0988d80b4473243dc /net-zope
parentDelete older ebuild. (diff)
downloadhistorical-f9bdb272751e96455e260a80861461e05b759f75.tar.gz
historical-f9bdb272751e96455e260a80861461e05b759f75.tar.bz2
historical-f9bdb272751e96455e260a80861461e05b759f75.zip
Version bump.
Package-Manager: portage-2.2.0_alpha24_p11/cvs/Linux x86_64
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/acquisition/ChangeLog10
-rw-r--r--net-zope/acquisition/Manifest6
-rw-r--r--net-zope/acquisition/acquisition-2.13.6.ebuild53
3 files changed, 64 insertions, 5 deletions
diff --git a/net-zope/acquisition/ChangeLog b/net-zope/acquisition/ChangeLog
index 75d9d0fb500a..ed4f03177d06 100644
--- a/net-zope/acquisition/ChangeLog
+++ b/net-zope/acquisition/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/acquisition
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/acquisition/ChangeLog,v 1.10 2010/11/28 22:05:23 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/acquisition/ChangeLog,v 1.11 2011/02/19 18:13:27 arfrever Exp $
+
+*acquisition-2.13.6 (19 Feb 2011)
+
+ 19 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -acquisition-2.13.5.ebuild, +acquisition-2.13.6.ebuild:
+ Version bump.
28 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
acquisition-2.13.5.ebuild:
diff --git a/net-zope/acquisition/Manifest b/net-zope/acquisition/Manifest
index 1e467779cb8e..e0c010ac2527 100644
--- a/net-zope/acquisition/Manifest
+++ b/net-zope/acquisition/Manifest
@@ -1,4 +1,4 @@
-DIST Acquisition-2.13.5.zip 69945 RMD160 c7435177c1368efc6388b468999e4a262b0e80be SHA1 33b642cfae5897a9693516c6343584b0f6e0f128 SHA256 b297560c298c3eb37c96dae1a790c4c000ea58ae5ea24d269db25056eb845cf2
-EBUILD acquisition-2.13.5.ebuild 1447 RMD160 d2b909a96b8549c48e40916507076365d0075286 SHA1 dfd5a8602cb05de117c39773107f91cb8f071c30 SHA256 2563b48102aa8f8e0fd5f702f01ccfef93cbff67ad940ded18c8492c56028d00
-MISC ChangeLog 1810 RMD160 475c6b74834142f1bee5dd4b6a466fb8573c8555 SHA1 46a6ab7b6c8398e68ee7c5f8ab1b4bac6bb30677 SHA256 b4a393a86632f18c54a2ad9fb9c48d55a833f416b0c4d6c86e039ccdd8483a40
+DIST Acquisition-2.13.6.zip 70607 RMD160 599ea5bf1dcee3446a56aeec51f6e88342c4bad8 SHA1 ae09cc94403c478c2e0bebd75597667226992abd SHA256 05b06a8d74e855e1910ded44e3b4cd971f29ee8a1c8d5ac39797bf1e2eedb144
+EBUILD acquisition-2.13.6.ebuild 1447 RMD160 afd149ed18ab6231b13a32fed1d8d785ec501e95 SHA1 2d862e60d86e687f8e2badc1bfb23c3bc5aaf894 SHA256 afe4cd5c28427ccd4f7f56b8d63243367417613d1b4a408dfbfc43e0b01de45c
+MISC ChangeLog 1993 RMD160 602d4225171b9f2f0e122f24010802bff6ff215e SHA1 56ea2d340b33db6b5cfed36f41f4478c543edb25 SHA256 3425b4ff618b3fb345d1071d88f5757f94a51a4835c73af0b1029a8b836fdce1
MISC metadata.xml 183 RMD160 0e2d86898897ee70cc1f6e9ceb76d00388d3b2fa SHA1 19635a9dfa15036e341a7cbdd8cbd018db62be82 SHA256 f480763451083d2f7be8fc23d38e02952ccc383b4cc65e103a9901a0907ce50d
diff --git a/net-zope/acquisition/acquisition-2.13.6.ebuild b/net-zope/acquisition/acquisition-2.13.6.ebuild
new file mode 100644
index 000000000000..039fecd61bac
--- /dev/null
+++ b/net-zope/acquisition/acquisition-2.13.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/acquisition/acquisition-2.13.6.ebuild,v 1.1 2011/02/19 18:13:27 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Acquisition"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Acquisition is a mechanism that allows objects to obtain attributes from the containment hierarchy they're in."
+HOMEPAGE="http://pypi.python.org/pypi/Acquisition"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/extensionclass
+ net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="CHANGES.txt src/Acquisition/README.txt"
+PYTHON_MODNAME="${MY_PN}"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in Acquisition; do
+ ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
+ done
+}
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+
+ delete_tests() {
+ rm -f "${ED}$(python_get_sitedir)/Acquisition/tests.py"
+ }
+ python_execute_function -q delete_tests
+}