summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-19 17:46:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-19 17:46:58 +0000
commitec3f1c379e9c1f4170f3e991b3483c53ca4ad294 (patch)
tree29810185b04c6b039bb950729546e2e1aa9ce128 /net-zope/zope-security/zope-security-3.8.0.ebuild
parentDelete older ebuild. (diff)
downloadhistorical-ec3f1c379e9c1f4170f3e991b3483c53ca4ad294.tar.gz
historical-ec3f1c379e9c1f4170f3e991b3483c53ca4ad294.tar.bz2
historical-ec3f1c379e9c1f4170f3e991b3483c53ca4ad294.zip
Version bump.
Package-Manager: portage-2.2.0_alpha9_p4/cvs/Linux x86_64
Diffstat (limited to 'net-zope/zope-security/zope-security-3.8.0.ebuild')
-rw-r--r--net-zope/zope-security/zope-security-3.8.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-zope/zope-security/zope-security-3.8.0.ebuild b/net-zope/zope-security/zope-security-3.8.0.ebuild
new file mode 100644
index 000000000000..3e8ed7a65aeb
--- /dev/null
+++ b/net-zope/zope-security/zope-security-3.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/zope-security-3.8.0.ebuild,v 1.1 2010/12/19 17:43:11 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope Security Framework"
+HOMEPAGE="http://pypi.python.org/pypi/zope.security"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytz
+ dev-python/restrictedpython
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-exceptions
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-proxy
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN/-//}"
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}