summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-03-05 17:23:14 +0000
committerAron Griffis <agriffis@gentoo.org>2003-03-05 17:23:14 +0000
commit8ba27490d9757ee1089b1995c7ae71f490745aa7 (patch)
tree3a031a8151f807ceb0694040efb4147d98330f97 /net-www
parentnew version (diff)
downloadhistorical-8ba27490d9757ee1089b1995c7ae71f490745aa7.tar.gz
historical-8ba27490d9757ee1089b1995c7ae71f490745aa7.tar.bz2
historical-8ba27490d9757ee1089b1995c7ae71f490745aa7.zip
fix bug 16905; mark stable on alpha
Diffstat (limited to 'net-www')
-rw-r--r--net-www/w3m/ChangeLog6
-rw-r--r--net-www/w3m/files/w3m-0.4-alpha.patch26
-rw-r--r--net-www/w3m/w3m-0.4.ebuild14
3 files changed, 43 insertions, 3 deletions
diff --git a/net-www/w3m/ChangeLog b/net-www/w3m/ChangeLog
index c19be6a3acf8..c6714c93ecfa 100644
--- a/net-www/w3m/ChangeLog
+++ b/net-www/w3m/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-www/w3m
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/ChangeLog,v 1.18 2003/03/05 15:36:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/ChangeLog,v 1.19 2003/03/05 17:23:14 agriffis Exp $
*w3m-0.4 (05 Mar 2003)
+ 05 Mar 2003; Aron Griffis <agriffis@gentoo.org> w3m-0.4.ebuild,
+ files/w3m-0.4-alpha.patch:
+ Fix bug #16905 by adding a patch for alpha. Mark alpha stable.
+
05 Mar 2003; Aron Griffis <agriffis@gentoo.org> w3m-0.4.ebuild:
Updated to 0.4. Fixed bug #16868 by updating the configuration monologue and
adding a sanity check at the end. Fixed bug #8879 by adding dep on
diff --git a/net-www/w3m/files/w3m-0.4-alpha.patch b/net-www/w3m/files/w3m-0.4-alpha.patch
new file mode 100644
index 000000000000..399990e56364
--- /dev/null
+++ b/net-www/w3m/files/w3m-0.4-alpha.patch
@@ -0,0 +1,26 @@
+--- w3m-0.4/gc/if_mach.c 2001-11-08 23:59:18.000000000 -0500
++++ w3m-0.4.new/gc/if_mach.c 2003-03-05 12:12:44.000000000 -0500
+@@ -1,5 +1,6 @@
+ /* Conditionally execute a command based on machine and OS from gcconfig.h */
+
++typedef char * ptr_t;
+ # include "private/gcconfig.h"
+ # include <stdio.h>
+ # include <string.h>
+--- w3m-0.4/gc/if_not_there.c 2001-11-08 23:59:18.000000000 -0500
++++ w3m-0.4.new/gc/if_not_there.c 2003-03-05 12:13:10.000000000 -0500
+@@ -1,5 +1,7 @@
+ /* Conditionally execute a command based if the file argv[1] doesn't exist */
+ /* Except for execvp, we stick to ANSI C. */
++
++typedef char * ptr_t;
+ # include "private/gcconfig.h"
+ # include <stdio.h>
+ # include <stdlib.h>
+--- w3m-0.4/gc/threadlibs.c 2002-07-10 10:21:16.000000000 -0400
++++ w3m-0.4.new/gc/threadlibs.c 2003-03-05 12:13:42.000000000 -0500
+@@ -1,3 +1,4 @@
++typedef char * ptr_t;
+ # include "private/gcconfig.h"
+ # include <stdio.h>
+
diff --git a/net-www/w3m/w3m-0.4.ebuild b/net-www/w3m/w3m-0.4.ebuild
index 678f20d6c62a..3a36b5384333 100644
--- a/net-www/w3m/w3m-0.4.ebuild
+++ b/net-www/w3m/w3m-0.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/w3m-0.4.ebuild,v 1.1 2003/03/05 15:36:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m/w3m-0.4.ebuild,v 1.2 2003/03/05 17:23:14 agriffis Exp $
+
+inherit eutils
IUSE="gpm cjk imlib ssl"
@@ -11,7 +13,7 @@ HOMEPAGE="http://w3m.sourceforge.net/"
SLOT="0"
LICENSE="w3m"
-KEYWORDS="x86 ~sparc ~alpha ~ppc"
+KEYWORDS="x86 ~sparc alpha ~ppc"
DEPEND=">=sys-libs/ncurses-5.2-r3
>=sys-libs/zlib-1.1.3-r2
@@ -22,6 +24,14 @@ DEPEND=">=sys-libs/ncurses-5.2-r3
PROVIDE="virtual/textbrowser"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use alpha; then
+ epatch ${FILESDIR}/w3m-0.4-alpha.patch || die "epatch failed"
+ fi
+}
+
src_compile() {
# It seems to be hard to configure this program in any reasonable
# way.