summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-01 14:00:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-01 14:00:14 +0000
commit88d77a6b8f4d2c9f20c69c6143dad05f9f5b388a (patch)
treea75f4f45ba3ad9079ef4f55711f9cc029c8aa12b /net-www
parentnew TODO comments (extensive) (diff)
downloadhistorical-88d77a6b8f4d2c9f20c69c6143dad05f9f5b388a.tar.gz
historical-88d77a6b8f4d2c9f20c69c6143dad05f9f5b388a.tar.bz2
historical-88d77a6b8f4d2c9f20c69c6143dad05f9f5b388a.zip
*** empty log message ***
Diffstat (limited to 'net-www')
-rw-r--r--net-www/links/links-0.95-r1.ebuild2
-rw-r--r--net-www/lynx/lynx-2.8.3-r1.ebuild54
-rw-r--r--net-www/oops/oops-1.5.6.ebuild17
3 files changed, 47 insertions, 26 deletions
diff --git a/net-www/links/links-0.95-r1.ebuild b/net-www/links/links-0.95-r1.ebuild
index 3c03f7f3674f..31cb49f2435e 100644
--- a/net-www/links/links-0.95-r1.ebuild
+++ b/net-www/links/links-0.95-r1.ebuild
@@ -9,8 +9,8 @@ HOMEPAGE="http://artax.karlin.mff.cuni.cz/~mikulas/links"
DESCRIPTION="A links like console-based web browser"
DEPEND="virtual/glibc
- >=sys-libs/gpm-1.19.3
>=sys-libs/ncurses-5.1
+ >=sys-libs/gpm-1.19.3
ssl? ( >=dev-libs/openssl-0.9.6 )"
src_compile() {
diff --git a/net-www/lynx/lynx-2.8.3-r1.ebuild b/net-www/lynx/lynx-2.8.3-r1.ebuild
index 4b25f6148793..26d92ac3eec9 100644
--- a/net-www/lynx/lynx-2.8.3-r1.ebuild
+++ b/net-www/lynx/lynx-2.8.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.3-r1.ebuild,v 1.4 2000/11/02 08:31:53 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.3-r1.ebuild,v 1.5 2001/06/01 14:00:14 achim Exp $
# NOW HAS SSLeay Support (so it will use the SSLeay library if found to
# do SSL connections :)
@@ -16,40 +16,56 @@ HOMEPAGE="http://lynx.browser.org/"
DESCRIPTION="An excellent console-based web browser"
-DEPEND=">=sys-libs/glibc-2.1.3
- >=sys-libs/gpm-1.19.3
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )
>=sys-libs/ncurses-5.1
- >=dev-libs/openssl-0.9.6"
+ >=sys-libs/zlib-1.1.3
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
-src_compile() {
- export CFLAGS="${CFLAGS} -I/usr/include/openssl"
- try ./configure --prefix=/usr --enable-cgi-links \
- --enable-nsl-fork --libdir=/etc/lynx --enable-file-upload \
- --enable-libjs --enable-color-style --enable-scrollbar \
- --enable-nls --with-catgets --enable-included-msgs --with-zlib \
- --with-x
- try make
-}
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
src_unpack() {
unpack lynx-2.8.3.tar.gz
cd ${S}
- gzip -dc ${DISTDIR}/lynx-283-ssl.patch.gz | patch -p1
+ if [ "`use ssl`" ] ; then
+ gzip -dc ${DISTDIR}/lynx-283-ssl.patch.gz | patch -p1
+ fi
zcat ${O}/files/fr.po.gz > ${S}/po/fr.po
}
-src_install() {
- cd ${S}
+src_compile() {
+ local myconf
+ if [ "`use nls`" ] ; then
+ myconf="--enable-nls"
+ fi
+ if [ "`use ssl`" ] ; then
+ export CFLAGS="${CFLAGS} -I/usr/include/openssl"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share \
+ --libdir=/etc/lynx --enable-cgi-links \
+ --enable-nsl-fork --libdir=/etc/lynx --enable-file-upload \
+ --enable-libjs --enable-color-style --enable-scrollbar \
+ --enable-included-msgs --with-zlib $myconf
+
+ try make
+}
+
+
+src_install() {
+
into /
dodir /usr/bin
dodir /usr/share
dodir /etc/lynx
- try make prefix=${D}/usr datadir=${D}/usr/share libdir=${D}/etc/lynx install
- prepman
+ try make prefix=${D}/usr datadir=${D}/usr/share \
+ mandir=${D}/usr/share/man libdir=${D}/etc/lynx install
+
dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
docinto docs
- dodoc docs/*
+ dodoc docs/*
docinto lynx_help
dodoc lynx_help/*.txt
docinto html
diff --git a/net-www/oops/oops-1.5.6.ebuild b/net-www/oops/oops-1.5.6.ebuild
index c6227124999d..e79f694e43e2 100644
--- a/net-www/oops/oops-1.5.6.ebuild
+++ b/net-www/oops/oops-1.5.6.ebuild
@@ -1,14 +1,18 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/oops/oops-1.5.6.ebuild,v 1.5 2001/04/27 20:35:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/oops/oops-1.5.6.ebuild,v 1.6 2001/06/01 14:00:14 achim Exp $
S=${WORKDIR}/${P}
SRC_URI="http://zipper.paco.net/~igor/oops/oops-1.5.6.tar.gz"
HOMEPAGE="http://zipper.paco.net/~igor/oops.eng/"
DESCRIPTION="An advanced multithreaded caching web proxy"
-DEPEND="virtual/glibc >=sys-libs/db-3.2.3h dev-libs/libpcre ssl? ( >=dev-libs/openssl-0.9.6 )"
+DEPEND="virtual/glibc sys-devel/gcc
+ dev-libs/libpcre
+ sys-devel/flex"
+
+RDEPEND="virtual/glibc sys-devel/gcc"
src_unpack() {
unpack ${A}
@@ -19,7 +23,8 @@ src_unpack() {
}
src_compile() {
- try ./configure --prefix=/usr --libdir=/usr/lib/oops --enable-oops-user=squid --sysconfdir=/etc/oops --sbindir=/usr/sbin --with-regexp=pcre --localstatedir=/var/run/oops
+ try ./configure --prefix=/usr --libdir=/usr/lib/oops --enable-oops-user=squid \
+ --sysconfdir=/etc/oops --sbindir=/usr/sbin --with-regexp=pcre --localstatedir=/var/run/oops
cd src
cp config.h.in config.h.in.orig
sed -e '/STRERROR_R/d' config.h.in.orig > config.h.in
@@ -34,12 +39,12 @@ src_install() {
chown squid.squid ${D}
try make DESTDIR=${D} install
chmod -R g+srw ${D}/etc/oops
- chmod -R g+rw ${D}/etc/oops/*
+ chmod -R g+rw ${D}/etc/oops/*
insinto /etc/oops
doins ${FILESDIR}/oops.cfg
cd ${D}
-
+
#cleanups
rm -rf ${D}/usr/oops
rm -rf ${D}/usr/lib/oops/modules
@@ -55,7 +60,7 @@ src_install() {
do
if [ -f $x ]
then
- mv $x $x.eg
+ mv $x $x.eg
fi
done
done