summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-10-21 18:39:06 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-10-21 18:39:06 +0000
commit229d26e9be0c92769296df5a8912f5dac843e415 (patch)
tree3a4f7f3ea168f873c83218df70f8cefa50fc8319 /net-www
parentnew version (diff)
downloadhistorical-229d26e9be0c92769296df5a8912f5dac843e415.tar.gz
historical-229d26e9be0c92769296df5a8912f5dac843e415.tar.bz2
historical-229d26e9be0c92769296df5a8912f5dac843e415.zip
new version
Diffstat (limited to 'net-www')
-rw-r--r--net-www/oops/ChangeLog15
-rw-r--r--net-www/oops/files/digest-oops-1.5.221
-rw-r--r--net-www/oops/oops-1.5.22.ebuild110
3 files changed, 121 insertions, 5 deletions
diff --git a/net-www/oops/ChangeLog b/net-www/oops/ChangeLog
index 48fe2a709320..5b8b8d854109 100644
--- a/net-www/oops/ChangeLog
+++ b/net-www/oops/ChangeLog
@@ -1,13 +1,18 @@
# ChangeLog for net-www/oops
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/oops/ChangeLog,v 1.2 2002/07/14 20:25:23 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/oops/ChangeLog,v 1.3 2002/10/21 18:39:06 blizzy Exp $
-*oops-1.5.6 (1 Feb 2002)
+*oops-1.5.22 (21 Oct 2002)
- 14 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> oops-1.5.6.ebuild :
- Added LICENSE, KEYWORDS, SLOT.
+ 21 Oct 2002; Maik Schreiber <blizzy@gentoo.org> : New version, closes bug
+ #5990.
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+ 14 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> oops-1.5.6.ebuild: Added
+ LICENSE, KEYWORDS, SLOT.
+
+*oops-1.5.6 (01 Feb 2002)
+
+ 01 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog:
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
diff --git a/net-www/oops/files/digest-oops-1.5.22 b/net-www/oops/files/digest-oops-1.5.22
new file mode 100644
index 000000000000..f82c07ac72b8
--- /dev/null
+++ b/net-www/oops/files/digest-oops-1.5.22
@@ -0,0 +1 @@
+MD5 bd6f743fb4abc6cf08ae310b1927b211 oops-1.5.22.tar.gz 449116
diff --git a/net-www/oops/oops-1.5.22.ebuild b/net-www/oops/oops-1.5.22.ebuild
new file mode 100644
index 000000000000..01e77d9c29ff
--- /dev/null
+++ b/net-www/oops/oops-1.5.22.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/oops/oops-1.5.22.ebuild,v 1.1 2002/10/21 18:39:06 blizzy Exp $
+
+DESCRIPTION="An advanced multithreaded caching web proxy"
+HOMEPAGE="http://zipper.paco.net/~igor/oops.eng/"
+SRC_URI="http://zipper.paco.net/~igor/oops/${P}.tar.gz"
+KEYWORDS="~x86 ~sparc ~sparc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=""
+DEPEND="dev-libs/libpcre
+ sys-devel/flex"
+
+S="${WORKDIR}/${P}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:/usr/local/lib/libpcre:/usr/lib/libpcre:g' configure.orig > configure
+ cd ${S}/src/modules
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/oops \
+ --enable-oops-user=squid \
+ --sysconfdir=/etc/oops \
+ --sbindir=/usr/sbin \
+ --with-regexp=pcre \
+ --localstatedir=/var/run/oops \
+ || die "configure problem"
+
+ cd src
+ mv config.h.in config.h.in.orig
+ sed <config.h.in.orig >config.h.in \
+ -e '/STRERROR_R/d'
+ mv Makefile Makefile.orig
+ sed <Makefile.orig >Makefile \
+ -e "s|OOPS_LIBDIR = /usr/lib/oops|OOPS_LIBDIR = ${D}/usr/lib/oops|" \
+ -e "s|OOPS_SBINDIR = /usr/sbin|OOPS_SBINDIR = ${D}/usr/sbin|" \
+ -e "s|OOPS_SYSCONFDIR = /etc/oops|OOPS_SYSCONFDIR = ${D}/etc/oops|" \
+ -e "s|OOPS_LOCALSTATEDIR = /var/run/oops|OOPS_LOCALSTATEDIR = ${D}/var/run/oops|" \
+ -e "s|OOPSPATH=/usr/oops|OOPSPATH=${D}/usr/oops|"
+ cd ..
+ make || die "compile problem"
+}
+
+src_install() {
+ local x
+ local y
+
+ dodir /usr/sbin
+ chown squid:squid ${D}
+ make DESTDIR=${D} install || die "install problem"
+ chmod -R g+srw ${D}/etc/oops
+ chmod -R g+rw ${D}/etc/oops/*
+
+ insinto /etc/oops
+ doins ${FILESDIR}/oops.cfg
+ cd ${D}
+
+ # cleanups
+ rm -rf ${D}/usr/oops
+ rm -rf ${D}/usr/lib/oops/modules
+
+ # config files
+ cd ${D}/etc/oops
+ for y in . tables ; do
+ for x in ${y}/* ; do
+ if [ -f ${x} ] ; then
+ mv ${x} ${x}.eg
+ fi
+ done
+ done
+}
+
+pkg_postinst() {
+ local x
+ local y
+ local mylen
+ local newf
+
+ cd ${ROOT}/etc/oops
+ for y in . tables ; do
+ for x in ${y}/*.eg ; do
+ realf=`echo $x | sed -e 's/.eg$//'`
+ if [ ! -e ${realf} ] ; then
+ cp ${x} ${realf}
+ fi
+ done
+ done
+ if [ ! -e ${ROOT}/var/log/oops ] ; then
+ install -d -o squid -g squid -m0770 ${ROOT}/var/log/oops
+ chmod g+s ${ROOT}/var/log/oops
+ fi
+ if [ ! -e ${ROOT}/var/lib/oops/storage ] ; then
+ install -d -o squid -g squid -m0770 ${ROOT}/var/lib/oops/storage
+ fi
+ if [ ! -e ${ROOT}/var/lib/oops/db ] ; then
+ install -d -o squid -g squid -m0770 ${ROOT}/var/lib/oops/db
+ fi
+ if [ ! -e ${ROOT}/var/run/oops ] ; then
+ install -d -o squid -g squid -m0775 ${ROOT}/var/run/oops
+ chmod g+s ${ROOT}/var/run/oops
+ fi
+}