summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-25 08:59:03 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-25 08:59:03 +0000
commit31088d20edd1a7f571e9d1c7db131998c03392be (patch)
tree7870efd9696be686b06962eaf30d6ad3f8cfcfa5 /net-www/w3m-m17n/w3m-m17n-20030916.ebuild
parentEnables migemo if app-emacs/migemo is installed (diff)
downloadhistorical-31088d20edd1a7f571e9d1c7db131998c03392be.tar.gz
historical-31088d20edd1a7f571e9d1c7db131998c03392be.tar.bz2
historical-31088d20edd1a7f571e9d1c7db131998c03392be.zip
Enables migemo support if app-emacs/migemo is installed
Diffstat (limited to 'net-www/w3m-m17n/w3m-m17n-20030916.ebuild')
-rw-r--r--net-www/w3m-m17n/w3m-m17n-20030916.ebuild28
1 files changed, 12 insertions, 16 deletions
diff --git a/net-www/w3m-m17n/w3m-m17n-20030916.ebuild b/net-www/w3m-m17n/w3m-m17n-20030916.ebuild
index 9d6968ab4da5..911278d713ad 100644
--- a/net-www/w3m-m17n/w3m-m17n-20030916.ebuild
+++ b/net-www/w3m-m17n/w3m-m17n-20030916.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/w3m-m17n/w3m-m17n-20030916.ebuild,v 1.1 2003/09/20 17:51:14 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/w3m-m17n/w3m-m17n-20030916.ebuild,v 1.2 2003/09/25 08:58:57 usata Exp $
-IUSE="imlib gtk xface gpm ssl ipv6"
+IUSE="imlib gtk xface gpm ssl"
#IUSE="nls"
W3M_CVS_PV="1.860"
@@ -12,9 +12,6 @@ W3M_M17N_CVS_PV="1.859"
W3M_M17N_P="w3m-cvs-${W3M_M17N_CVS_PV}-m17n"
LIBWC_PV="20030224"
-#GC_PV="6.3alpha1"
-#GC_P="gc${GC_PV}"
-
DESCRIPTION="Lightweight text based WWW browser w3m with multilingual extension"
HOMEPAGE="http://w3m.sourceforge.net/
http://www2u.biglobe.ne.jp/~hsaka/w3m/
@@ -23,7 +20,6 @@ SRC_URI="http://dev.gentoo.org/~usata/distfiles/${W3M_P}.tar.gz
http://www.page.sannet.ne.jp/knabe/w3m/${W3M_M17N_P}-1.diff.gz
http://dev.gentoo.org/~usata/distfiles/libwc-${LIBWC_PV}.tar.gz"
# nls? ( http://www.page.sannet.ne.jp/knabe/w3m/${W3M_M17N_P}-nls-1.diff.gz)
-# http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${GC_P}.tar.gz
SLOT="0"
LICENSE="w3m"
@@ -51,19 +47,17 @@ src_unpack() {
unpack ${W3M_P}.tar.gz
cd ${S}
- #unpack ${GC_P}.tar.gz
- #mv ${GC_P} gc
-
# libwc doesn't come with w3m-m17n now
unpack libwc-${LIBWC_PV}.tar.gz
epatch ${DISTDIR}/${W3M_M17N_P}-1.diff.gz
+ epatch ${FILESDIR}/w3m-w3mman-gentoo.diff
#use nls && epatch ${DISTDIR}/${W3M_M17N_P}-nls-1.diff.gz
}
src_compile() {
- local myconf
+ local myconf migemo_command
if [ -n "`use imlib`" -o -n "`use gtk`" ] ; then
myconf="${myconf} --enable-image=x11,fb `use_enable xface`"
@@ -71,23 +65,25 @@ src_compile() {
myconf="${myconf} --enable-image=no"
fi
- # --enable-japanese=m
+ if has_version 'app-emacs/migemo' ; then
+ migemo_command="migemo -t egrep /usr/share/migemo/migemo-dict"
+ else
+ migemo_command="no"
+ fi
+
econf --program-suffix=-m17n \
--enable-keymap=w3m \
--with-editor=/usr/bin/nano \
--with-mailer=/bin/mail \
--with-browser=/usr/bin/mozilla \
--with-termlib=ncurses \
+ --with-migemo="${migemo_command}" \
`use_enable gpm mouse` \
- `use_enable ipv6` \
`use_enable ssl digest-auth` \
`use_with ssl` \
${myconf} || die
- emake package=w3m-m17n \
- W3M=w3m-m17n \
- MAN='env LC_MESSAGES=$${LC_MESSAGES:-$${LC_ALL:-$${LANG}}} LANG=C man'\
- || die "make failed"
+ emake package=w3m-m17n W3M=w3m-m17n || die "make failed"
}
src_install() {