summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-03 09:19:42 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-03 09:19:42 +0000
commitae0ca8bc70ac8c553765c8347e506ede3e68b775 (patch)
tree5817b8b8bcd619924a3a03e9e9ee036746003558 /net-www/skipstone
parentoptional tetex dependency typo fix (diff)
downloadhistorical-ae0ca8bc70ac8c553765c8347e506ede3e68b775.tar.gz
historical-ae0ca8bc70ac8c553765c8347e506ede3e68b775.tar.bz2
historical-ae0ca8bc70ac8c553765c8347e506ede3e68b775.zip
compiles against newer moz
Diffstat (limited to 'net-www/skipstone')
-rw-r--r--net-www/skipstone/ChangeLog15
-rw-r--r--net-www/skipstone/files/digest-skipstone-0.8.31
-rw-r--r--net-www/skipstone/files/digest-skipstone-0.8.3-r12
-rw-r--r--net-www/skipstone/skipstone-0.8.3-r1.ebuild (renamed from net-www/skipstone/skipstone-0.8.3.ebuild)20
4 files changed, 29 insertions, 9 deletions
diff --git a/net-www/skipstone/ChangeLog b/net-www/skipstone/ChangeLog
index f556de5edb2c..1b06723dc043 100644
--- a/net-www/skipstone/ChangeLog
+++ b/net-www/skipstone/ChangeLog
@@ -1,11 +1,20 @@
# ChangeLog for net-www/skipstone
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/ChangeLog,v 1.14 2002/12/13 11:00:28 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/ChangeLog,v 1.15 2003/02/03 09:19:42 seemant Exp $
+
+*skipstone-0.8.3-r1 (03 Feb 2003)
+
+ 03 Feb 2003; Seemant Kulleen <seemant@gentoo.org>
+ skipstone-0.8.3-r1.ebuild files/digest-skipstone-0.8.3-r1 :
+
+ Nicholas Wourms (dragon@gentoo) found a fix from debian to make skipstone
+ compile against the newer mozillas. Fixes bug #14616 by Alex Tananaev
+ <antissimo@mail.spbnit.ru>
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
*skipstone-0.8.3 (25 Jun 2002)
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+
02 Nov 2002; Seemant Kulleen <seemant@gentoo.org> skipstone-0.8.3.ebuild :
Upstream's cvs server is non-responsive, and muhri himself seems away from
diff --git a/net-www/skipstone/files/digest-skipstone-0.8.3 b/net-www/skipstone/files/digest-skipstone-0.8.3
deleted file mode 100644
index fee611470429..000000000000
--- a/net-www/skipstone/files/digest-skipstone-0.8.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d44324e3664723c2cbe82ce60464dc51 skipstone-0.8.3.tar.gz 417469
diff --git a/net-www/skipstone/files/digest-skipstone-0.8.3-r1 b/net-www/skipstone/files/digest-skipstone-0.8.3-r1
new file mode 100644
index 000000000000..e12500b2e26b
--- /dev/null
+++ b/net-www/skipstone/files/digest-skipstone-0.8.3-r1
@@ -0,0 +1,2 @@
+MD5 d44324e3664723c2cbe82ce60464dc51 skipstone-0.8.3.tar.gz 417469
+MD5 03d0e264e909d2c170ab30ca5c80ba93 skipstone-0.8.3-gentoo.diff.bz2 1797
diff --git a/net-www/skipstone/skipstone-0.8.3.ebuild b/net-www/skipstone/skipstone-0.8.3-r1.ebuild
index 358282c0abff..3d535e058886 100644
--- a/net-www/skipstone/skipstone-0.8.3.ebuild
+++ b/net-www/skipstone/skipstone-0.8.3-r1.ebuild
@@ -1,31 +1,41 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/skipstone-0.8.3.ebuild,v 1.10 2002/12/09 04:33:20 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/skipstone-0.8.3-r1.ebuild,v 1.1 2003/02/03 09:19:42 seemant Exp $
+
+inherit eutils
+
+IUSE="nls"
DESCRIPTION="GTK+ based web browser based on the Mozilla engine"
-SRC_URI="http://www.muhri.net/skipstone/${P}.tar.gz"
+SRC_URI="http://www.muhri.net/skipstone/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
HOMEPAGE="http://www.muhri.net/skipstone/"
-KEYWORDS="x86 ppc sparc "
SLOT="0"
LICENSE="GPL-2"
-IUSE="nls"
+KEYWORDS="x86 ppc sparc"
DEPEND="net-www/mozilla
=x11-libs/gtk+-1.2*"
+
RDEPEND="${DEPEND}
nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
+
if [ `use nls` ] ; then
cd ${S}/src
xgettext -k_ -kN_ ../src/*.[ch] -o ../locale/skipstone.pot
# Now we apply a patch to rid the files of duplicate translations
cd ${WORKDIR}
- patch -p0 < ${FILESDIR}/${PN}-gentoo.patch
+ epatch ${FILESDIR}/${PN}-gentoo.patch
fi
+ # patch to compile against newer mozilla, thanks to the debian project
+ # (found by nicholas wourms <dragon@gentoo.org>)
+ epatch ${WORKDIR}/${P}-gentoo.diff
+
}
src_compile() {