summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-02 16:18:13 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-02 16:18:13 +0000
commit1169ab24aed51a0885a97d66c0a2475749c25723 (patch)
treed60d8883fbd1fba3a6c2b5dec9e48e23fd61a4bf /net-www/phpBB
parentadding initial s390 support (diff)
downloadhistorical-1169ab24aed51a0885a97d66c0a2475749c25723.tar.gz
historical-1169ab24aed51a0885a97d66c0a2475749c25723.tar.bz2
historical-1169ab24aed51a0885a97d66c0a2475749c25723.zip
this is 2.0.6d which is a security release. see bug 43474
Diffstat (limited to 'net-www/phpBB')
-rw-r--r--net-www/phpBB/ChangeLog9
-rw-r--r--net-www/phpBB/Manifest8
-rw-r--r--net-www/phpBB/files/digest-phpBB-2.0.6-r21
-rw-r--r--net-www/phpBB/phpBB-2.0.6-r2.ebuild50
4 files changed, 63 insertions, 5 deletions
diff --git a/net-www/phpBB/ChangeLog b/net-www/phpBB/ChangeLog
index eab0bced996d..b9453ca5c93f 100644
--- a/net-www/phpBB/ChangeLog
+++ b/net-www/phpBB/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/phpBB
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.9 2003/12/15 20:42:30 stuart Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/ChangeLog,v 1.10 2004/03/02 16:18:13 mholzer Exp $
+
+*phpBB-2.0.6-r2 (02 Mar 2004)
+
+ 02 Mar 2004; Martin Holzer <mholzer@gentoo.org> phpBB-2.0.6-r2.ebuild:
+ this is 2.0.6d which is a security release. see bug 43474
15 Dec 2003; Stuart Herbert <stuart@gentoo.org> phpBB-2.0.6-r1.ebuild:
Fix for bug #32636
diff --git a/net-www/phpBB/Manifest b/net-www/phpBB/Manifest
index 9406a6cbe392..845e8a041889 100644
--- a/net-www/phpBB/Manifest
+++ b/net-www/phpBB/Manifest
@@ -1,5 +1,7 @@
-MD5 2bcc15b387e45c0342ace8fe007ada43 files/digest-phpBB-2.0.6-r1 64
-MD5 baf12ebb39a1b14b5b0bf0fa9320eba8 files/phpBB-2.0.6-security.patch 248
MD5 7c07009af241c73521e5d2cc39467d25 phpBB-2.0.6-r1.ebuild 1331
-MD5 f95f4ac71aec17956b6a4d671b9dd414 ChangeLog 1242
MD5 c339473e0ff43da76eb2f2607c441921 metadata.xml 280
+MD5 ed96d073875432ebb4463a7dc762fb03 ChangeLog 1409
+MD5 0329a803da692e6e047fdd0f9b1d21b5 phpBB-2.0.6-r2.ebuild 1261
+MD5 81edef11555fd2672d5ccc894ce8b711 files/digest-phpBB-2.0.6-r2 64
+MD5 2bcc15b387e45c0342ace8fe007ada43 files/digest-phpBB-2.0.6-r1 64
+MD5 baf12ebb39a1b14b5b0bf0fa9320eba8 files/phpBB-2.0.6-security.patch 248
diff --git a/net-www/phpBB/files/digest-phpBB-2.0.6-r2 b/net-www/phpBB/files/digest-phpBB-2.0.6-r2
new file mode 100644
index 000000000000..a0e46018c53b
--- /dev/null
+++ b/net-www/phpBB/files/digest-phpBB-2.0.6-r2
@@ -0,0 +1 @@
+MD5 b3e462b3696e483bda81b281eca2c828 phpBB-2.0.6.tar.bz2 453896
diff --git a/net-www/phpBB/phpBB-2.0.6-r2.ebuild b/net-www/phpBB/phpBB-2.0.6-r2.ebuild
new file mode 100644
index 000000000000..72b57edcfade
--- /dev/null
+++ b/net-www/phpBB/phpBB-2.0.6-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/phpBB/phpBB-2.0.6-r2.ebuild,v 1.1 2004/03/02 16:18:13 mholzer Exp $
+
+inherit webapp-apache
+
+DESCRIPTION="phpBB is a high powered, fully scalable, and highly customisable open-source bulletin board package."
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="mirror://sourceforge/phpbb/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+RESTRICT="nomirror"
+
+DEPEND=">=sys-devel/patch-2.5.9"
+RDEPEND="virtual/php"
+
+S=${WORKDIR}/${PN}2
+
+pkg_setup() {
+ webapp-detect || NO_WEBSERVER=1
+
+ webapp-pkg_setup "${NO_WEBSERVER}"
+
+ if [ -d ${HTTPD_ROOT}/phpbb ] ; then
+ ewarn "You need to unmerge your old phpBB version first."
+ ewarn "phpBB will be installed into ${HTTPD_ROOT}/phpbb"
+ ewarn "directly instead of a version-dependant directory."
+ die "need to unmerge old version first"
+ fi
+
+ einfo "Installing for ${WEBAPP_SERVER}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_install() {
+ webapp-mkdirs
+
+ dodir "${HTTPD_ROOT}/phpbb"
+ cp -a * "${D}/${HTTPD_ROOT}/phpbb"
+ dodoc ${S}/docs/*
+
+ cd "${D}/${HTTPD_ROOT}"
+ chown -R "${HTTPD_USER}:${HTTPD_GROUP}" "${D}/${HTTPD_ROOT}/phpbb"
+}