summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-05-17 00:38:16 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-05-17 00:38:16 +0000
commit4c3a6bd5e131d26b2844aad970c4ec9669a4971d (patch)
tree61a4cb681cba25e05c0bbdeb2f60ced085437534 /net-www/mplayerplug-in/mplayerplug-in-3.40-r1.ebuild
parentMove the virtual/libstdc++ inside the x86 check as we don't need it on amd64.... (diff)
downloadhistorical-4c3a6bd5e131d26b2844aad970c4ec9669a4971d.tar.gz
historical-4c3a6bd5e131d26b2844aad970c4ec9669a4971d.tar.bz2
historical-4c3a6bd5e131d26b2844aad970c4ec9669a4971d.zip
Fix get_libdir typo.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'net-www/mplayerplug-in/mplayerplug-in-3.40-r1.ebuild')
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.40-r1.ebuild97
1 files changed, 97 insertions, 0 deletions
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.40-r1.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.40-r1.ebuild
new file mode 100644
index 000000000000..e7f3d5e43e06
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.40-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.40-r1.ebuild,v 1.1 2007/05/17 00:38:16 josejx Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="mplayer plug-in for Gecko based browsers"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="gtk divx gmedia mplayer-bin realmedia quicktime wmp"
+
+DEPEND="
+ || ( www-client/mozilla-firefox
+ www-client/seamonkey
+ www-client/epiphany
+ )
+ || ( ( x11-libs/libXpm
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1
+ )
+ mplayer-bin? ( media-video/mplayer-bin )
+ !mplayer-bin? ( >=media-video/mplayer-1.0_pre5 )
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-3.40-cflags.patch
+ epatch ${FILESDIR}/${PN}-gcc4.patch
+ ### Adds support for 32 bit binary mplayer on amd64
+ if use mplayer-bin; then
+ epatch ${FILESDIR}/${PN}-mplayer-bin.patch
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ # We force gtk2 now because moz only compiles against gtk2
+ if use gtk; then
+ myconf="${myconf} --enable-gtk2"
+ else
+ ewarn "For playback controls, you must enable gtk support."
+ myconf="${myconf} --enable-x"
+ fi
+
+ # Media Playback Support (bug #145517)
+ econf \
+ ${myconf} \
+ $(use_enable divx dvx) \
+ $(use_enable gmedia gmp) \
+ $(use_enable realmedia rm) \
+ $(use_enable quicktime qt) \
+ $(use_enable wmp) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/nsbrowser/plugins
+ doexe mplayerplug-in.so || die "plugin failed"
+
+ insinto /usr/$(get_libdir)/nsbrowser/plugins
+ doins mplayerplug-in.xpt || die "xpt failed"
+
+ PLUGINS="gmp rm qt wmp dvx"
+
+ for plugin in ${PLUGINS}; do
+ if [ -e "mplayerplug-in-${plugin}.so" ]; then
+ ### Install the plugin
+ exeinto /usr/$(get_libdir)/nsbrowser/plugins
+ doexe "mplayerplug-in-${plugin}.so" || die "plugin ${plugin} failed"
+ ### Install the xpt
+ insinto /usr/$(get_libdir)/nsbrowser/plugins
+ doins "mplayerplug-in-${plugin}.xpt" || die "plugin ${plugin} xpt failed"
+ fi
+ done
+
+ insinto /etc
+ doins mplayerplug-in.conf
+
+ dodoc ChangeLog INSTALL README DOCS/tech/*.txt
+}